Tech Support Guy banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
i have a dell inspiron 1721 and i keep having the same problem with my charger. i get a new one, from dell.com, and it works great for a couple weeks to a month, but after that i get the same message of "the charger plugged in is not a dell 90wat charger, your operating system will run slower, please plug in a dell 90wat charger." When i got this message the first couple of times i just got a new one thinking i did something wrong, and the charger im using right now is not a dell charger, it's a knock-off one that i got for half the price on a discount website. This charger however did the same exact thing as my dell chargers, it worked great for a few weeks then gave me the message about it not being a dell 90wat charger although it is slighty different because this time it says it is plugged in but not charging.

any ideas what is wrong?
 

·
Premium Member
Joined
·
52,926 Posts
...It's a Dell.

On that same screen it should say how to disable that message. Sometimes you have to update the BIOS to actual be able to get rid of that message or be able to use non-Dell adapters. Latest BIOS is here: http://support.dell.com/support/dow...-1&impid=-1&formatcnt=1&libid=1&fileid=252216

But if its not charging the battery then there could actually be an issue. Possibly with the charging circuits on the mainboard, or there's possibly something damaging the adapters, like brownouts or surges. Does the jack in the laptop seem loose?
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top