Tech Support Guy banner

Laptop Bios keeps changing CD setting to none

2810 Views 18 Replies 4 Participants Last post by  mason
My Gateway solo 2550 laptop keeps changing the cd setting in the bios to none I change it and save it. and when I go into WIndows it says there is no D drive. I go back into the Bios and its changed right back to none. I have selected the three diferent setting just to see what would happen and each time even after saving and exiting it goes back to none. Thinking it may be the CD player I changed the player. Same thing happens. Any ideas?
Not open for further replies.
1 - 19 of 19 Posts
Is this a hardware profile thing. You can set up different hardware profiles in Windoze...usually for a laptop, you have a profile for docked and a profile for un-docked. Maybe the default profile is one where it thinks it doesn't have a CD-ROM drive? Just a thought.
I'll answer both post with this one... Its an internal cd rom. Its not a windows issue. When it boots up
after the power on self test it list the drives and then it says no cd rom present. then it goes into the windows
screen. I do not see how it could be related to Windows and also the undocking docking profile is still the same
undocked. Its been that way since I have had this machine. Im wondering if at all possible that maybe the bios is corrupt.
I dont know Im out of ideas
Boot with a boot disk w/cdrom support.......put a cd in the the cdrom prompt (which will be one letter ahead from where you know it), type the drive letter, like

and press enter
does it change?

If so, type
and press enter
do you get a directory?
If the changes in the BIOS are not being saved it seems like your battery on the motherboard is dead.

Replace that and see if the problem is corrected. Batteries are not that expensive.
This is the message I get when I use the start up disk:
This Driver is provided by Oak Technology Inc...
OTC-91xv352 (C) copyright Oak Technology Inc.

Device name :MSCD001
No Drive Found, Aborting Installation

I appreciate all the help
The drive is not being seen at the bios level.....can you pop into the bios setup and see if you can re-recognize the drives......also, if there are settings for IDE controllers, be sure they are set to enabled.
Exactly the bois isnt seeing the drive.. I set it and save it and then once I get out of the Bios it goes right back to no cd. There is no ide controller setting in the bios.
Hmm, even if the battery is dying, you should be able to see it on you are saying, even though you save changes, with a boot floppy disk in the drive, you still can't access the cdrom?

Scenario is this, you have a boot disk in the floppy drive, you access bios setup, you see the cdrom, you save changes, the computer continues to boot to the floppy disk, you choose with cdrom support, and you can't get to the cdrom there?
thats exacty whats going on
In the bios setup, is there an entry for ide controllers? If so be sure they are set to ENABLED.
There isNO entry for ide controllers in the bios
What settings are options in the bios? USER, AUTO? When you say you set it, does it actually show information on the CDROM?
I have the option for user auto atapi and none. I have tried all of the option and it revert right
back to none once I select and save. I had forgotten all about this and I dont think it makes a
difference but its possible. I took the hard drive out of another Solo 2550 and stuck it in the one
thats giving me the problem. Is it possible that Windows or the cd drivers are messing with the system
because it came from another machine?
I don't think so, because it never gets to the desktop with a cdrom drive being recognized in the device manager, correct?

And I just thought of this, and sometimes it is a stupid question, but it is possible to exit the bios without saving are sure you are SAVING CHANGES prior to exiting, correct? Sometimes it's difficult to tell............I would try the ATAPI setting myself.
tried exiting without saving also. the cd setting still reverts back to none. Like I stated before I have tried all the settings and it still goes back to none.
Is the cd getting power? Does the tray open and close?
there is power to the cd it opens closes when a cd is inserted it will spin and then stop. Remember I stated that I have also tried another cd player and they both act the same
1 - 19 of 19 Posts
Not open for further replies.