Tech Support Guy banner

Keyboard unresponsive so I can't get into BIOS

377 Views 10 Replies 2 Participants Last post by  crjdriver
so i bought a Z590 VISION D and i am having promblems with its bios when i have my keyboard plugged in its not resposive when bios promt comes up
i have a razer huntsman mini keybaord and i have regular acer monitors

it shows f12 to go bios but my keyboard unrespsonsive even when i plug it in and plug it out

i have an i9 10850kf
32gb vegence ram
1080ti 11 gb
msi 360 ml aio
lian li sl 120mm fans
Not open for further replies.
1 - 11 of 11 Posts
Some keyboards have a function lock to enable/disable the function keys. Check to see if you have disabled the function or "F" keys.
You have six different usb ports on the back of that motherboard, try a different port and/or a different keyboard.
i have use every port on my motherboard and still doesn’t work
Have you used a different keyboard? If not, do so.
I have actually used 2 other keyboards I use a red dragon and a cyber power membrane one and both also didn’t work
Have you tried clearing cmos on the new motherboard?
yeah i have removed the cmos battery for 2 minutes and replugged back in
That is not how you clear cmos properly.
1 Remove the pw cord from the pw supply
2 Press the ON button to discharge the pw supply
3 Clear cmos with the clear pins for a minimum of 10 seconds
4 Replace pw cord and pw ON
If the above will not work, I would consider doing a RMA for the motherboard.
where’s the clear pins on their motherboard ?
where's the clear pins on their motherboard ?
Page 24 of the online manual shows a picture of the clear cmos pins.
1 - 11 of 11 Posts
Not open for further replies.