Tech Support Guy banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I am in the process of setting up a simple home network. I have two computers. The first, which acts as the host, is a Dell running Windows XP Home SP2. It is connected to the Internet via a SpeedTouch USB ADSL modem. This connection works perfectly fine. The second computer is running Windows XP Professional SP2. The two are connected by a Cat5E crossover cable. File and printer sharing are fully functional. Both computers are running ZoneAlarm free edition. Each has the Trusted Zone set to Off, and the ethernet adapters connecting the two are in the Trusted Zone. The Internet connection has sharing enabled via Windows ICS. It shows up in the Internet Gateway section of Network Connections on the second computer and in the system tray as well. It says it is connected; however, I cannot access the Internet at all from that computer. I've tried both Firefox and Internet Explorer. I've also tried using Gaim to see if it is simply HTTP that isn't working, but the various IM protocols do not work either. The programs are cleared for access with ZoneAlarm. I've run out of ideas as to how to get the second computer to have Internet access.

Configuration of Host Computer:
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Dan>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : greatroom
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : Yes
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connecti
on
Physical Address. . . . . . . . . : 00-0C-F1-D6-5B-B8
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.0.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Ethernet adapter SpeedTouch:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Alcatel SpeedTouch(tm) USB ADSL RFC1
483
Physical Address. . . . . . . . . : 00-90-D0-38-4B-8A
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.222.198
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

PPP adapter ATT DSL:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : 00-53-45-00-00-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 68.255.5.98
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 68.255.5.98
DNS Servers . . . . . . . . . . . : 68.94.156.1
151.164.8.201
NetBIOS over Tcpip. . . . . . . . : Disabled
Configuration of Client Computer:
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Dan>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : danmain
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : MSHOME.NET

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : MSHOME.NET
Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
Physical Address. . . . . . . . . : 00-17-31-00-5B-0C
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.0.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 192.168.0.1
 

·
Super Moderator
Joined
·
82,234 Posts
My initial bet is that ZA is blocking. I don't use it, but doesn't Zone Alarm have a separate option to "allow internet access through this computer"?

The following is written for "router" but may show some useful info when tried on the XP Pro.

First determine if the problem PC is really communicating with the router when it claims to be connected.

To open a Command Window: Start - Run - cmd (command in 98SE) - OK

To determine a computer's IP address and router's IP address: open a Command Window and type
ipconfig /all

The "Gateway" is the router's IP address.

Now for some troubleshooting. Following is how to use ping to test for communication with your router, the internet, and the internet with symbolic name.

1. On the PC open a Command window and type
ping IProuter (where IProuter is the IP address of the router)

Do you get Replies, or do you get packets lost?

IF you got replies,
2. ping 66.94.234.13 (or any other internet address you know)

Do you get Replies, or do you get packets lost?

If you got replies,
3. ping www.yahoo.com (or any other internet name)

Do you get Replies, or do you get packets lost?
 

·
Registered
Joined
·
1,729 Posts
I had this setup for a few months then finally gave in and got a router. Trust me, this ICS is unreliable.

Shouldn't you have trustedzone on?
Also check that 192.168.0.1 is in zonealarms trusted section and anywhere else, such as trusted computers if that exists.

Ages since I used zonealarm. Blocked too much for my liking.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Well, somehow the issue resolved itself. I really don't know quite how. For hours the stupid thing wasn't working. I didn't change anything, then all of a sudden when I accidentally clicked on a help link it brought up a page and now my Internet is working. I had tried adding 192.168.0.1 to the trusted list in ZoneAlarm earlier today and it hadn't worked. I honestly don't know what fixed it. My guess is I'll be having trouble with ICS in the near future, but for now this is solved.
 

·
Registered
Joined
·
1,729 Posts
jackdw said:
I had this setup for a few months then finally gave in and got a router. Trust me, this ICS is unreliable.
Point proved :D

Glad you got it sorted, it does that. Now watch it stop as weirdly as it started.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top