Tech Support Guy banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Here's the information on the situation.

Host
Netfirms

Directory where I placed the files:
[mysiteDOTcom/test/.htaccess
mysiteDOTcom/test/.htpasswd

File I'm trying to password protect:
mysiteDOTcom//test/Concertss.html

.htaccess configuration:
AuthName "Secure Place"
AuthType Basic
AuthUserFile /ww/test/.htpasswd
AuthGroupfile /dev/null
require valid-user

.htpasswd configuration:
tim:$apr1$cC2 $qgqPSriDTRP7tHLsb69Mw.

I created the .htpasswd file with the program ".htpasswd.exe" from the DOS prompt. I created the .htaccess file by going to DOS and typing edit.

I am able to go to mysiteDOTcom//test/ConcertssDOThtml and get prompted for a password, however the password does not work. From reading around this site, I see I need to get the server path of the .htpasswd file. How do I get this? I am using flashFXP and frontpage and all I can get is the URL path.

Is there anything else I am doing wrong?

P.S it's ridiculous that we cant post URLS
 

·
Registered
Joined
·
2,609 Posts
You should remove the AuthGroupFile line, it is not needed.

Your htpasswd file should not be store in the same directory that holds your served files. Move it outside this directory, location isn't important.

The AuthUserFile is the path to this file on your machine.

What is the exact command you used to create the password file?

If you have access to Apache conf file, I would put your authentication commands in there and avoid needing the .htaccess files.

More info can be found here: httpd.apache.org/docs/howto/auth.html
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top