Tech Support Guy banner
Status
Not open for further replies.
1 - 20 of 36 Posts

·
Registered
Joined
·
211 Posts
Discussion Starter · #1 ·
OK.. this has happened for the fourth time in a week now... i boot up my computer ( win98 + Red hat 9) and the bootloader just appears half.... like Li-
and it hangs there.
So i put in my windows98 bootable floppy and fdisk /mbr. Now the last three times it happened, i just booted into win98 and using PartitionMagic 8 formatted the Linux partition.
I'm tired of formatting the linux partition and having to set up linux all over again... :( Is there any way i could restore the bootloader or perhaps boot into linux and install the bootloader or something??? I haven't created a linux bootable floppy.
Please keep in mind that i'm a real noob at linux... so try keeping the answer really simple.
With Regards,
Umesh
 

·
Registered
Joined
·
103 Posts
What version/distribution of linux are you using? Also do you know if you were using Grub or Lilo as your boot loader?

The process is to generally boot in with a boot/repair disk and rererun the bootloader installation.

For grub enter something like:
/sbin/grub-install /dev/hda

For lilo enter:

/sbin/lilo

And it should set up lilo as it was set up originally from the settings in /etc/lilo.conf
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #7 ·
guys.... i am able to now boot into linux. This is what i did last night..
I popped in the cd 1 of red hat 9 and booted off the cd.... then i went ahead with an upgrade of the red hat installation but didnt select any packages to be upgraded.At the end of the upgrade? process, i was asked if i wanted to create a boot diskette... i put a floppy in... and a bootable floppy was created.
Now i am able to boot into linux if i have the floppy in the drive. But how do i install a bootloader as well?
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #9 ·
hey.. when i type lilo as a root user... i get a command not found error.
By the way, i did as Grinler said above,
# /sbin/grub-install /dev/hda
So now grub is installed.. :) Problem solved! Thanks to all of u !
With Regards,
Umesh
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #11 ·
:) yeah.. grub it is now what i have. Incase it gets corrupted again i have the bootable floppy and now i know the command to install grub again!
By the way, Anyone got an idea why i get the error "command not found" when i type pico ?? Pico loads up at my classes where i learn linux ( its red hat 6 there) but at home on my rh9 system, its not there.i did a custom install n didnt see pico anywhere...correct me if i'm wrong.
With Regards,
Umesh
 

·
Registered
Joined
·
1,240 Posts
I use nano ^.^
 

·
Registered
Joined
·
3 Posts
Hey Everyone.. I'm new Here.. But anyway.. I have about the same problem as he did.. so i figured i wouldnt waste a new thread.. I had pretty bad luck with redhat linux9.. i recently installed it using the lilo boot loader first.. but i was new to partitions and bootloaders.. so i didnt install it right... and couldnt load windows.. but i could still use linux.. after i decided to remove linux.. i still had the bootloader.. but hadnt made a bootdisk for redhat.. my computer is getting old and i havent upgraded much of the hardware in a while.. so i had no A drive on it.. But i got an A Drive for it and with my luck... i had my plug n play cd rom on top of my box.. (my cd burner wont load autorun files) and guess what happened.. the cd rom fell and the first redhat cd got caught up.. and it scratched the hell out of the cd around the edge.. so now the cd wont even install anything.. much less let me make a bootdisk.. right now im using my cousins really terrible small hard drive as a substitute until i fix this... i just get a li- command on startup... and i cant reinstall linux.. which i dont have on their anymore.. so if anyone could send me the contents of the boot disk.. (if thatd work with a corrupt bootloader) or if you know any other fix.. plleeasse reply to this thread or contact me @ [email protected] Regards.. Rich
 
1 - 20 of 36 Posts
Status
Not open for further replies.
Top