Tech Support Guy banner
Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
I have checked into this problem and followed instructions to go to edit/prefs/advanced/system etc. and all the boxes are checked appropriately and still several programs want to open in Netscape 4.76 instead of 6.1.....any suggestions?

I do not want to delete 4.76 as yet but it is rather annoying to have the other browser opening for certain programs....

Thanks so much!
Terri
 

·
Registered
Joined
·
3,208 Posts
The first step in the process is to set Internet Explorer so it will not ask whether it should be your default browser:

Open up Internet Explorer.
Under the View menu, click Internet Options (in 4.x browsers) or Options (in 3.x browsers).
In the dialog box that appears, click the tab labeled Programs.
At the bottom of the dialog box you will see a checkbox that reads "Internet Explorer should check to see whether it is the default browser." Make sure this box is not checked.
Click OK and close Internet Explorer.
Next, set Communicator to be your default browser:
Run Communicator by choosing Programs and then Netscape Communicator from the Start menu or by double-clicking the Communicator icon on your desktop.
You should be presented with a dialog box that reads "Navigator is no longer registered to handle Internet Shortcuts. Would you like to register Navigator as your default browser?" Click Yes.
If you do not encounter this dialog box when starting Communicator, you will need to reset Communicator to bring this dialog box up the next time you launch Netscape:
Exit Communicator. Important: Make sure Communicator and all of its components are NOT running.
Go to the Netscape directory on your hard drive. Open up your hard drive (usually labeled C: drive). Next, find and open the folder labeled Program Files. Inside you will find a folder labeled Netscape. Important: This is the default location for Netscape; the location on your particular computer may differ. If necessary, you can use the Find feature in the Start menu to locate it.
Inside the Netscape folder, open up the folder labeled Users.
Inside Users, open the folder with the same name as your Communicator profile. There may be only one folder, but if there is more than one, choose the one that coincides with the profile you select when you launch Netscape.
Back up the file called prefs.js somewhere on your hard drive. Note: This file may simply be labeled prefs.
Open this file by using a text editor. By default the pref.js file is associated with Netscape. In order to open this file with a text editor, select the file with a right click and choose the menu item called Open With. In the window that appears, select Notepad or Notepad.exe from the list. Next, make sure that the "Always use this program to open this type of file" checkbox at the bottom of the window is unchecked. Then, click the OK button to close this window and open the pref.js file.
In this file, you will see a line (you may have to scroll down a bit) that reads:

user_pref("browser.wfe.ignore_def_check", true);
Leaving the line otherwise untouched, change the word true to the word false. Note: Disregard the text at the top of this page that reads "This is a generated file! Do not edit." If you do not see the above line in your prefs file, Communicator may already be configured as your default browser.

Save the file (choose Save from the File menu) and close the window.
Next time you launch Communicator, you will be presented with a dialog box asking if you would like Netscape to be set as your default browser. Choose Yes.
If upon launching Communicator, you still do not get the dialog box asking if you would like to set Communicator as your default browser, you may have incorrectly edited your prefs.js file. Locate the saved prefs.js file that you made (in step 5) and replace the newly altered file with this saved file. You can do this by repeating steps 2, 3, and 4 (to open up your profile folder) and replacing the prefs.js file in your profile folder with the one you previously saved. From here, go back to step 5 and repeat the rest of the process, making sure to follow the instructions in step 7 very carefully.
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #3 ·
You supplied me with such a wonderful reply and I hesitate to say it did not work/. Why? Because my settings are all for Netscape - not IE! They always wee with Netscape. Perhaps I did not explain my problem clear enough. When I start up, Netscape 6.1 does open - however when I go to certain programs - they automatically open Netscape 4.76 and do not use the newer version of Netscape....that is the problem.
Accept my apologies and perhaps you would know of another answer to my problem. Thanks so much!
Terri
 

·
Registered
Joined
·
3,208 Posts
Bear with me. Im working on it. I dont run Netscape but am trying to learn some about it to help.

Can you give me an idea of which programs you are refering to?
 

·
Registered
Joined
·
1,220 Posts
mylan,

In Netscape 6, go to Edit > Preferences > Advanced > System.

On the right-hand side, under the heading 'Windows should use Netscape 6 to handle these protocols:', select 'http: [Hypertext Transfer Protocol]' and 'https: [Secure HTTP]'.
Then click OK.

Now when ever you click on a link to a web page from your email (or other program) it will open it in NS 6.
 

Attachments

·
Registered
Joined
·
3,208 Posts
Thats why I asked which programs. I cant seem to find the article now, but I had read about the need to uninstall 4.7 to prevent this sort of thing but I wanted to be sure before I suggested it.
 

·
Registered
Joined
·
3,208 Posts
Pulled this from Rick Selby's site. Might work.

Change your default browser:
Open control panel
Click Internet options
Click on the Programs tab
Change the html editor for the default browser
Change the E-mail for the default E-mail program and so on down the list for each option.
OR
Go to start
Click on run
Type in "explorer" without the quotes
Click on edit
Click on options
Click on file types
.htm .html and change the program they are opened by to X:\Program Files\Netscape\Netscape instead of iexplore.exe

Also, from microsoft.

http://support.microsoft.com/support/kb/articles/Q280/7/50.ASP
 

·
Registered
Joined
·
1,220 Posts
Yes, this is baffling. :confused:

I have NS 4.7, NS 6.1, and IE 6 installed on my system and I was able to make it work without having to uninstall NS 4.7.

Hopefully DoyceJ's latest suggestions will work.
 

·
Registered
Joined
·
1 Posts
I have Netscape 4.79, Netscape 6.2 and IE 6.0, and I have not been able to figure out a way to switch the default browser from Netscape 4.79 to 6.2.

The Internet Options on the Control Panel appear to be solely an IE thing.
 

·
Registered
Joined
·
3,208 Posts
Open Internet Explorer
Click on 'Tools' on the menu
Select Internet Options
Click on the 'Programs' tab
At the bottom will be a white box that says:
"Internet Explorer should check to see whether it is the default browser" - make sure the box is checked
Close Internet Explorer
Open it again
A small box will pop up saying that "IE V.X (X being your version number) is currently not your default browser, would you like to make it your default browser?" Click "No" and close Internet Explorer
Open up Netscape 6.2 and a box should pop up asking if you want to make Netscape your default browser, click "Yes" (if for some reason this box does not pop up, depending on your version) it automatically makes Netscape the default browser.
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top