Tech Support Guy banner
Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Alright. I'm running on a Compaq Presario with Vista Professional. There was a point around November when IE started experiencing freezing problems so I removed some of the add-ons and it worked fine. Now, recently (maybe within the past two weeks or so) my laptop has become increasingly slow and freezes when doing several tasks at once. This happens more often on the Internet (the page has semi-loaded but I can't click on anything and the blue-green loading circle is spinning on the top tab) it normally takes 20-30 seconds to load a page, if it doesn't freeze within that time. It's not always a complete freeze, I wait for two minutes then its back to its slow snail pace. But, there are instances where it freezes completely and I have to shut it down manually.

I don't get any error messages when I shut it down via holding down the power button. I've tried to fix the problem myself, I've scanned for viruses with AVG and I've scanned with Ad-Aware and Spybot but they didn't come up with anything that should slow my computer down this much, just a few tracking cookies that Ad-Aware picked up.

Help is greatly appreciated, thank-you in advance.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
It's not just IE that's freezing up, IE freezes up more because I normally do more things on the Internet rather than on the actual desktop of my computer unless I'm working on something in a word processor. While using Firefox may be a good idea, I'll wait a bit on it before I join the masses. In case my problem doesn't actually involve IE at all rather something on my system.
 

·
Registered
Joined
·
159 Posts
1GB is good enough for minimal performance. 2 GB is the sweet spot for Vista. It may be that you have too many programs open and is short of RAM because you stated that your other programs are freezing as well.

However, you also said in your first post that the sites were taking 20-30 seconds to load... it could be many things but I think the best thing to do is to install another browser (Firefox) and to see if the problem is with IE or with your computer.

If you still don't want to move to Firefox, it could be a firewall or some kind of program you're using that works with IE. I know Spybot comes with some bonuses such as TeaTimer and IE protection. If you used one of those, try disabling the IE protection and see what happens.

Is there freezing even when you've only opened a few programs or tabs?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
Yes, the freezing happens when opening even a few programs. For instance if I was opening a word document, the window I'm opening it from will freeze, and sometimes my computer. I know for certain that Spybot isn't causing problems as I downloaded it late last night to check my computer for spyware. I'll try downloading Firefox, though.
 

·
Registered
Joined
·
694 Posts
If you have not already turned them off, you may have too many programmes running unnecessarily at startup too.

Type Windows Defender in the Start search box, then click on it. Click on Tools at the top of the page, and then software explorer. Click on each one you don't need automatically running at startup, and disable.

You can also do this from msconfig - just type that in the start searchbox and go into the startup tab.

It may be too that some of your memory is shared with your graphics card, which will reduce the amount available for use.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #11 ·
Okay. I've since downloaded Firefox and I've disabled programs that don't need to be running at start up. Despite the fact that Firefox is faster and I'm liking that fact, I'm still experiencing the freezing and overall slowness of my computer. Also, the time it takes to boot up is quite slower than normal. Last time I booted up my laptop it did say it needed to scan my C drive for consisteny I believe if that has anything to do with it. Although, it didn't fix anything, just scanned it as far as I know. I'd also like to note again that this has only been happening recently. Late January to mid February at the earliest maybe. I haven't had problems quite like this before.
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top