Tech Support Guy banner

External HDD poor performance: physical or logical failure?

3802 Views 27 Replies 5 Participants Last post by  Angelcat
I have multiple external hard drives, mostly full of blu-ray rips, and none of it is backed up. This is the first time I've had a problem with one of the drives.

Windows takes a long time to recognize the drive, but it does eventually appear in Computer. All files open and run slowly, and videos don't play properly. File transfer speeds aren't right either. Transferring files to or from the drive takes a long time, going at less than 1mb/s, while it used to go 20mb/s. This is the only drive experiencing these problems.

I tried error-checking, but it was also slow, and I'm not sure it's working correctly (I don't know how it's supposed to work, but basically it takes a long time and I'm not sure when it's finished; I think it didn't find problems but I'm not sure). IIRC defragmentation analyzation was at 1% for ages so I cancelled it. I'm scared to try stuff because I don't want to destroy the drive for good and lose everything. I did run CMD and used the "dir" command to get a text file list of everything on the drive, in case I lose everything.

I don't know whether it's physical or logical failure. When I discovered the problem this morning, the drive was extremely hot, along with some of the other drives (but like I said this is the only one with any problems). Yesterday, a lot of files were moved from this drive to another and vice versa, but again, the same is true for some of the other drives. It hasn't sounded strange at all, nor has it made any clicking noises. I've tried switching the USB leads, USB ports, and power leads, all to no avail.

What do you think the problem is, and what should I do?

The drive is still under 2-year warranty, which expires either December 2014 or July 2015. It's a 3 TB drive, and it's almost full, so I don't know how I'd get all those files off while it's performing the way it is.

It's a Seagate 3 TB Expansion Desk, and it's 1 of 9 external hard drives.

Windows 7 Home Premium, Service Pack 1, 64-bit
Intel Core i3 CPU 550 @ 3.20GHz
3.00 GB RAM
Any help would be hugely appreciated! Let me know if I left out some information.
See less See more
Not open for further replies.
1 - 20 of 28 Posts
Hi and welcome to TSG.

First thing to remember is pretty much all harddrives fail at some point, its not a case of 'IF' its a case of 'WHEN'?

You say the drive is almost full, how full as a percentage? If the drive is almost full this could significantly impact performance.

If it is failing you need to get the data off if you want to save it. Personally, I would start copying the data off ASAP. If it fails while you are taking data off at least you have saved some of it, if it fails while your 'testing' you could loose everything!

Seatools can be used to test the drive in DOS or Windows (dependant on the version), this is a utility by Seagate for testing their drives.

This should give you a definitive answer or at least a good indication if there is a problem with the drive. For a 3TB drive it can take quite a bit of time to test, even more so if the drive has very little free space.
See less See more
Hi Tanis, thanks for the response

I know that about harddrives failing at some point, and I've admittedly been putting it out of my mind. Across the 9 drives I have almost exactly 20 tb of storage space, and it's all gradually built up over time. It'd be expensive to buy 20 tb worth of backup drives, but this finally might make me do that.

It has 224 GB free of a total 2785 GB, so that's 92% full. Last week I bought a new drive, and before then it was 99% full.

It'd take about 1000-2000 hours to take everything off the drive if my calculations are correct, so I'd only expect to be able to save a small fraction of it if anything.

I'll try Seatools now. I probably should have searched for something like that. I did come across Seagate file recovery software, but I didn't know if it was appropriate because I didn't know exactly what the problem was.
I'm having trouble using Seatools at the moment and am still looking for solutions. While the program says "USB: Scanning for supported drives. Please wait...", I receive the dialog box "stxcon has stopped working". Seatools doesn't close, but the window seems like it isn't responding and isn't making progress on the scan.
If you can't run Seatools through Windows then it might be worth downloading the DOS version and creating a bootable disk to run it from. The link above will take you through a step by step of creating a bootable .ISO etc. If it runs OK from the bootable disk lets see what results we get from that.

What is the exact make and model of the PC, assuming its a 'big brand' name like a HP, Dell, Acer etc?
If its a custom / self build whats the make and model of motherboard, RAM, CPU, power supply etc .. the more info the better.
If you are unsure use the TSG System Info utility (see my signature).

Have you changed or upgraded any hardware in it?
How old is the machine, roughly?
Okay, I used the bootable DOS version. Unfortunately, it only found 1 hard drive in the scan. I have 6 Seagates and 3 WD drives, and it found one of the WD drives for some reason. None of the others were listed. Here's a photo of how it looked:

Reading this, I came across the known limitations and system requirements. "SeaTools may not find or access hard disk drives when CMOS is set to "none" for those drives." I don't know what this means or how to check. Otherwise, the other issues aren't relevant, and I meet the system requirements. Any idea what my problem might be? I'm gonna try again after I finish this post.

Thanks for that utility. Here's my info:
Tech Support Guy System Info Utility version
OS Version: Microsoft Windows 7 Home Premium, Service Pack 1, 64 bit
Processor: Intel(R) Core(TM) i3 CPU 550 @ 3.20GHz, Intel64 Family 6 Model 37 Stepping 5
Processor Count: 4
RAM: 2999 Mb
Graphics Card: Intel(R) HD Graphics, 1275 Mb
Hard Drives: C: Total - 229325 MB, Free - 110529 MB; D: Total - 230103 MB, Free - 52063 MB; K: Total - 2861575 MB, Free - 323666 MB; L: Total - 2861575 MB, Free - 321634 MB; M: Total - 2861554 MB, Free - 388386 MB; N: Total - 2861575 MB, Free - 229580 MB; O: Total - 953867 MB, Free - 107088 MB; P: Total - 2861575 MB, Free - 420441 MB; Q: Total - 1907725 MB, Free - 342733 MB; R: Total - 1430799 MB, Free - 157794 MB;
Motherboard: Packard Bell, imedia S3810
Antivirus: avast! Antivirus, Updated and Enabled
"N" is the faulty drive. I think "M" is the drive that showed up in the scan, but I'm not totally sure. Only 8 drives are listed there because the 9th isn't plugged in at the moment. I haven't made any hardware changes to the computer. I've never opened the case. I think I got the machine in December 2010, so it's 3 and a half years old.
See less See more
You could probably try to disconnect the other drives leaving just the OS drive and the problem drive before running the tests with Seatools or WD Lifeguard Diagnostics.
When I turned the PC on this morning it would no longer recognize the drive. I hadn't touched it since yesterday when I tried the second Seatools scan. The drive still vibrates when it's on, but the computer doesn't recognize it. Anyway, I just unplugged it. I guess it's dead and I should just accept the losses and use the warranty? Yesterday I looked at sending it to their labs for them to recover data, but it costs hundreds of £ and isn't worth it to me.

Thanks for the response, Frozwire. I would have tried both of those things, but I guess it's too late now.

Thanks for the help guys. Shall I mark this as solved, just leave it, or is there anything else I could try?
As its an external drive, I assume in a caddy, it could be the caddy that has failed so probably worth a few more tests to check.

You will need to open the caddy and remove the drive, then connect the drive to the PC using the internal cables etc. While you are testing, I would do as Frozwire suggests and disconnect all the other drives, this will make it much easier to identify the one you are interested in.

Im not familiar with how to use Seatools so can't help much there, I just know of its existance.

As it has a Packard Bell motherboard I assume its one of their models, can you give us the exact model number?
If I remove the drive from its case, will that void the warranty?

Do I need any leads or anything to be able to connect this drive internally or should I already have everything I need?

The model is Packard Bell imedia S3810, according to System. Is that what you're looking for?
Good point, if it is still under warranty then yes that will void it .... so don't do that :) my mistake, forget they were still under warranty.

I would double check it on any other PC to confirm that it isn't recognise there either (if possible) then return under warranty. If the warranty identifies a caddy failure then I would try and get them to either transfer the data onto a replacement unit or ensure they give you the same drive back in a new caddy.
Okay, I tried it with a second computer (laptop). It recognized the drive, which is more than the PC did. When I doubled clicked it, it hung around loading for a while, then I received the message "You need to format the disk in drive G: before you can use it. Do you want to format it?", to which I clicked cancel. After more loading, I got the message "G:\ is not accessible. Data error (cyclic redundancy check).". I clicked OK and haven't done anything since.

Should I continue with the plan to use Seatools and/or WD Lifeguard, or should I do something else, given these error messages?

Edit: I'm running CHKDSK to see what it says.
Well, if you still want the files from that external drive I suggest that you better image/clone that drive to good working drive of the same capacity using ddrescue. Then go for the warranty claim after you have already imaged/cloned the drive.
Cloning or imaging a drive that you can not read or access is going to be difficult!

This sounds more and more like a drive / caddy hardware problem to me, trying it on a different PC and still not being able to access it further indicates the drive/caddy/cable is the problem. Hard to say exactly which without doing more detailed diagnosis, but if it is under warranty then that is the route I would go now.

Unfortunately, you may have to accept the loss of data :(
I'm still running CHKDSK. I hear that it can run for days straight. That seems to be the case here. It is finding problems. It's been stuck on 10% almost the whole time, but the number of files tested is slowly going up. I could type the exact info CHKDSK is giving me if that'd be helpful to anyone in understanding what's wrong. Maybe it was a logical problem rather than a physical one after all. It still hasn't made any weird noises, nor has it even gotten especially hot while plugged into the laptop. I was ready to throw in the towel and use the warranty but I don't know any more.

Thanks for the help so far guys.
The CHKDSK ran for days and stayed at 10% so I cancelled it. I haven't done anything with it for a couple of days and it's been unplugged from any computer during that time. Should I accept the data loss and try and format the drive to see if it was a logical failure? If it still doesn't work then, I'll use the warranty.

Also, maybe a stupid question, but I bought the product from Amazon. Should I go through Amazon or Seagate for warranty?
Why don't you try crystal disc info. You will have the condition of all your hard drives installed in an instant.

Note: Careful when installing it. Use custom settings so you won't install other programs offered in there.

UPDATE: You may want to try this site first. Download the zip file.
I don't understand what crystal disc info is or what it does.

Weirdly, my main computer can access the drive again, and I don't even get the errors that I got with the laptop. It still has the same performance problems though. But at least I can see the files in a folder again.

I forgot to mention that I used TeraCopy to move the files mentioned in the original post.

I just have a feeling that it's not a hardware problem and that there's bad sectors or something like that. I want to run CHKDSK but it could run for months so is it worth it? I went to use ddrescue but I don't understand that either; just downloading it seems complicated; is it for linux? Is there other popular software I could use to try and recover the data. I don't even have another drive to move the files onto right now.

I just need general advice on what I should do, thanks.
I just tried the Seagate File Recovery software that I mentioned earlier:

After 16 minutes I received the dialog box from the image. The in-lab recovery they talk of is too expensive to be worth it. Does this message likely mean it's a physical failure and that I should FINALLY use my warranty or could it still be software-related?
See less See more
Crystal disc Info is a free program that lets you know the condition of your hard drive, how many hours it has run, etc. It will automatically tell you if your hard drive is in good condition or needs to be replaced sooner or later.
1 - 20 of 28 Posts
Not open for further replies.