Tech Support Guy banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello,

I am running Windows Vista on a Dell Computer. I have previously used my Toshiba External Hard Drive on the computer, however after i reinstalled windows it does not work.

I connect the USB port from the Hard Drive to the Computer, the light on the Hard Drive turns on. The computer recognized it and installed the proper drivers. When I go to "Computer" I do not see my hard drive in the Hard Drive Section. I however do see a "Removable Disk (U:)" In the "Devices with Removable Storage." I double click the "Removable Disk (U:)" and I receive the following text "Please insert a disk into Removable Disk (U:)"

When I click start and right click on "Computer" click Manage I arrive at Computer Management. Under Storage i click on Disk Management and in the bottom portion I see 3 Drives. Disk 0 Basic 74.50GB ONLINE and there are 3 Sections next to that one has no label and says 39MB HEALTHY, the next RECOVERY (D:) 10GB NTFS HEALTHY, and the last one (C:) 64.46GB NTFS HEALTHY. Under Disk 0 I see Disk 1 Removable (U:) No Media. However, when I right click on it and click Properties Toshiba 2.0USB Drive R00 USB DRIVE under device status it says : This Device is working properly.

So I see that my computer does recognize my External Hard drive, but I can not access it at all! This is becoming very frusterating I have tried many solutions on google, however none of them have worked for me!

Please help me access it..

Thanks in advance!
 

·
Registered
Joined
·
12,661 Posts
HAve you tried the drive on a different computer?
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top