Tech Support Guy banner

Dell Dimension Amber Light Issue can still start using CMOS reset

1660 Views 17 Replies 3 Participants Last post by  managed
Well My Dell Dimension c521 started having that Solid amber light issue and so I started testing and everything works as it should however I stil get the solid amber. So I set the PSU switch to off and put the Cmos jumper on reset and push the PSU switch to on and Success! the pc started and ran normally for hours. However every time I turn the PC off In order to restart it I have to reset the CMOS which annoys me because I lose all my settings and My Graphics drivers get resetted back to that Standard VGA Graphics driver from Microsoft. Any Ideas? It all started when I removed and re installed my Proccesor.
Windows 7 Ultimate 64 Bit
AMD Ahtlon 64 x2 5000+ 2.6 Ghz
Not open for further replies.
1 - 18 of 18 Posts
Try fitting a new Cmos battery.
I did and it stayed the same, it annoys me because this issue wont let me update my Graphic drivers and can't play any games because of it. I also even replaced my PSU without any luck. I'm using the Dimension C521 right now
Yes I can understand how frustrating it must be.

You could try flashing/updating the Bios but that does have risks.
I was thinking of doing that but will it work even if I have the latest BIOS? I tried but the its an exe file and says i'm running an unsupported system
I don't know if it will let you install the latest Bios again if you have it already.

It may not work in Windows 8.1, is this the one you tried, for Vista 64 bit ? :-
Yes I tried this one for Win 7 64 and says Unsupported system when running the .exe file
Ok, I meant Win 7 64 bit.

You could try right-clicking the EXE file then Properties > Compatibility tab, then tick the 'Run this program in ...' box and select your version of Vista with the down arrow.

I don't know if that will work but give it a try.
Tried that too on all compability modes and none worked. I while back i had this light issue happen and replacing the board fixed my issue but just cant afford to replace it again
Not sure if there is a way to reflash bios trough ms dos boot from exe
I tried opening the EXE in WinRAR but it just shows a single file called A17AS.BIN

There are instructions for using a DOS bootable Usb stick on the Dell link I posted earlier but I don't see how that could work with this EXE.

I have to logout now, I'll check this thread again in about 12 hours.
Ok so I rereplaced my supossed new cmos battery with a new for sure cmos battery and now my time and drivers stay Normal and now I was able to update my drivers but I still have the issue of having to use jumper in order to start
That exe started in my Win7 32bit system and it popped up a message about attached devices before updating BIOS (I'm not going to run it further in my Thinkpad just in case it does update my BIOS).
It looks to me as though that exe is a Windows 32bit executable. If you really need me to check, I could try the same exe under Win98 and XP to see if it does the same.
Since the new Cmos battery has made a difference I doubt flashing the Bios is necessary any more.

I would have said it's the PSU but you already replaced that.
Was the replacement PSU exactly the same as the original ? Was it new ?
I replaced the logisys 500 psu with a logisys 700 PSU brand new. the motherboard is on a CM Storm Scout Case so that I could fit my GTX 580 and a nice H70 corsair liquid cooler.
Looking online it seems Logisys PSU's aren't very good. Could you try another PSU ?
Afraid I can't. Why would the psu be an issue now if the pc boots when moving the jumper on the cmos and works, I can even over clock my gpu and cpu and play high demanding pc games or even leave the pc running for long and stays running
I'm as baffled as you are and it was just something that's relatively easy to do if there's a spare PSU available.
1 - 18 of 18 Posts
Not open for further replies.