Tech Support Guy banner

CPI and USB drivers missing

675 Views 11 Replies 4 Participants Last post by  petr
My Win 95 installation CD-ROM (with USB Support)fails to install USB support properly. Anybody know what I should do?

Not open for further replies.
1 - 12 of 12 Posts
Hi Petr and welcome to TSG.

Are you sure you have USB support? Only some of the latter versions of 95 supported it.
Try this article for details and checks:

For USB use I would recommend upgrading to Win 98 or later, if you can, as 95 may not be that stable in USB mode.

There's a thread on these forums somewhere on this subject, I'll see if I can locate it for you.
Here's that thread link for you:

When you say it fails to install it correctly, have you checked that USB is enabled in your BIOS setup?
Originally posted by Mike C UK
Here's that thread link for you:

When you say it fails to install it correctly, have you checked that USB is enabled in your BIOS setup?
No, I hven't, and will do so as soon as as I get off the net. Thanks.

The symptoms are that when I start windows, it sometimes "finds" new hardware, and attempts to locate a driver for it, but can"t from the original CD-ROM. A "PCI bus" shows up twice under "System Devices" heading og the "System" icon of "Control Panel", the second one with an exclamaiton mark through it, and under "Other Devices" I have two "PCI Universal Serial Bus", again the second one with warning. In both cases the properties show no drivers and attempting to load the drivers from WIN95 fails. Deleting these and using only the ones that "are working properly" still doesn't find the USB port, and when restarting I get an "unknown device", a CPI bus, which seems to install automatically, but isn't working when I check it.

I'll let you know if the BIOS switch was disabled.

I don't know if you've already done this or not, but on your windows 95 CD, there should be a file called "usbsupp" somewhere. I cannot remember the exact path, but it might be in a folder called admin, or utilities or something. Try do a search on the CD for an executable with the word usb in it. You should be able to find this, then just double click it, and restart when prompted.

Good luck
Yes, all 4 of my USB ports are enabled in the BIOS. Too bad, it would have been too easy to fix if they weren't...
Originally posted by columbo

... there should be a file called "usbsupp" somewhere ...

Thanks. I did find that, and installed it, and now have "USB Supplement to OSR2" under the "Add/Remove Programs" of Control Panel. However... the main reason I tried to get the USB to work is that I am trying to install a USB high speed modem, and the computer just doesn't see it.
Where I seem to be finding some problems is in the "Device Manager" under "System" icon of the Control Panel - it shows 2 PCI USB's connected to the "PCI bus", which is connected to "Computer". It also shows another "PCI bus" connected to "PnP BIOS", and this one has the warning exclamation mark on it, and under General Properties for this PCI bus it shows "Device failure: Try changing the driver for this device. If that doesn't work, see your hardware documentation. (Code 2.)"
I tried updating driver, never found one it would accept on my Win95 CD-ROM. I tried removing it, but on Boot-Up it comes up as "unknown Device" and the Wizard install it again, in the same place, with the same problems.
I also tried installing manually any USB device I could form the list, just to see if anything would work, managed to install "Generic USB Hub", which now shows connected directly to "Computer", but it still doesn't see my modem.
I also tried installing the modem manually, using the ".inf" driver supplied with the "Have Disk" option in "Add New Hardware", but it doesn't accept it. I have tried it as "Modem", "HSFModem", "Network Adapters" and "System Devices" with no result.

Any ideas?
Originally posted by Mike C UK
Here's that thread link for you:

Thanks for the link. According to the information acquired there, I am running OSR 2.1 (4.00.950B) with USB support. I have installed the USB support according to the instructions, with no palpable result other than it showing as installed. The problem (see my previous post) remains, and I cannot connect to my USB modem.
Perhaps I should try to get a copy of Win98, though they are hard to find these days...

My main concern is whether I should return the modem (supplied by my ISP as part of High-Speed package) and stick with the s..l..o..w dial-up, or spend time upgrading my OS before I even try the modem and service to see if I like it...
USB support in W95 is iffy at best. USB support in W98 is much more reliable. You can find a W98 full edition or a W98 Upgrade CD here if need be.

But are you sure it's a USB modem or does it just have a USB Network adapter plugged into it?

Most modems will also have a standard RJ45 connection in addition to a USB port. If that's the case, you'll be able to just install a PCI network card in the PC and run CAT cable to it rather than using the supplied USB network adapter.

BTW, as far as trying it to see if you like it, if you've been using 56 dialup, there's no doubt in my mind what so ever that you'll like it so I'd do whatever it takes to get the high speed connection installed.
Hi again Petr

Glad the link was useful. Subject to you checking out what Bryan says here I would def. upgrade to 98 and stick with the idea of going beyond 56k modems.
I may live in the center of England but my internet connection is at the end of a 12km phone line and crawls along - oh, another snail has just raced by! At least your costs to improve are less than the house move costs I will face if want to upgrade.
Hope it all comes together for you.
Originally posted by Bryan

... are you sure it's a USB modem or does it just have a USB Network adapter plugged into it? ...

Yes, this modem is a part of my ISP's "High Speed Package", designed to share phoneline with existing voice equipment, and physically has only one cord, that attaches to USB port and has a little modular telephone jack inline to attach to existing phone line. It's powered from the USB port (as far as I can tell) and is fully software controllable. All it has is two LED's, one for USB, the other for ADSL. When I power-up my computer, the USB LED blinks twice (on power on, and on reset - when the computer goes "beep"), hence I assume that the connection is correct.

I guess I will look for Win98 tomorrow - any recommendations as to releases or versions (assuming I have a choice), the Microsoft bulletin Mike gave me a link to recommends "Second Edition", but it may be obsolete...

Thanks for the advice.

I guess that takes care of my problem as far as this thread is concerned, is there something I should do to close it, or is that your prerogative?
I spoke too soon! I finally managed to get Win98, second Edition, OME version. Now, how do I install it on my computer?
It was suggested to me to format my hard drive before installation of OME OS, to make sure there is nothing lingering in the background that could rear up and bite me later. So far so good, except, HOW DO I FORMAT MY HARD DRIVE? I don't think I can do it from the existing Win95, and I don't know how to do it from whatever remainder of DOS there is these days if I restart in DOS. And even if I succeed, how do I reboot the computer to install from CD-ROM? I have attempted to instruct my BIOS to boot from CD first, but that failed, either there is no boot sector on the CD or it just won't use it first. I do have a Win98 Startup disk (which was supplied to me with the installation of my Win95 !?? but I need some advice or instructions before I destroy my HD and/or the rest of my system...

1 - 12 of 12 Posts
Not open for further replies.