Tech Support Guy banner

Corrupted .NetFx 3.5 - cannot uninstall for a reinstall

1744 Views 9 Replies 5 Participants Last post by  plodr
After a crash, several of my programs complain that a "config file from microsoft .netfx is missing or corrupted". So in an attempt to repair it, i have uninstalled 4.0, 4.5, 4.5.1, and 4.5.2, with the programs still complaining about the corrupt files (and crashing)

So, I looked to .Net 3.5.
Programs and Features > Turn Windows Features on and off
As expected, .Net 3.5 comes up and is on. I try to untick it and click OK.

The progress bar appears, and fills up quickly, then hangs for a good 10+ minutes, only to error that "changes to the features couldn't be completed"

DISM /Online /Disable-Feature /FeatureName:NetFx3

Bar comes up, fills quickly, hangs at 100%... Error: 1603
Fatal error during installation.

I tried Enabling it... no error. "Enabled" correctly, then attempted to disable it again... same error.

Tried Microsoft's .Net Framework repair tool. All it did was re-register and restart the installer service... same error.
Attempted the "netfx cleanup tool" from ... 3.5 was still installed after cleanup... same error.
Checked the "netfx setup verification tool" from 2.0, 3.0, and 3.5, installed... no errors.

Took ownership over the entire C:\Windows\Microsoft.Net\ folder, and all it's contents... same error.
Returned ownership of said folder to NT SERVICE\TrustedInstaller ... same error.

I still cannot remove the .NetFx 3.5 installation, and something in it's config is still corrupted, so several of my programs still don't work.

Every time I restart my computer, after the windows "Starting" screen, but before my login appears, windows attempts to "apply updates" but fails. This occurs even should I restart my computer without doing anything.

Had I the option of a simple FFR, I would not be coming here hoping someone could give me advice, but I am at wit's end.

I have attached the DISM log file.

I am also now unable to install .Net 4.0+ which makes even more of my programs incapable of running.


See less See more
Not open for further replies.
1 - 10 of 10 Posts
System Restore would be your best bet. Restore system files and settings
There is, for some reason, no system restore points other than two created during my attempts to recover the dotnet framework last night. Would an SFC have any effect here?
Windows 7 came with .NET 3.5. I suspect that is why you are finding it impossible to remove.

Is this the site you are using?

Maybe repairing Windows 7 will repair .NET 3.5
I'm aware Windows 7 comes with it preinstalled, but it is (normally) removable via the "Turn Windows Features on and off" dialogue, and through DISM, which are essentially the same thing.

Yes, I used the tools provided by Aaron Stebner. The Verifier says 3.5 is installed fine, and the cleaner completes successfully, but doesn't actually remove it. It is, in fact, not installed fine, otherwise I would not be having trouble running programs that rely on .Net 3.5

Creating a system repair disk would work, if it was done before the system files got corrupted, and if I had any sort of disk drive.
Well if anything is going to work it'll be this. "No Data Will Be Lost In This Operation."

How to Do a Repair Install to Fix Windows 7
Revo doesn't show NET 3.5 in Windows 7 because it is part of the OS.
Geek Uninstaller only shows NET framework above NET 3.5.
Advanced Uninstaller Pro only shows NET framework above 3.5.
keltic1der, read the first post. He used Aaron Stebner's tool and confirmed for me in post #5 that he used the tool you are pointing him to.
He is still having problems.
Yes, I used the tools provided by Aaron Stebner. The Verifier says 3.5 is installed fine, and the cleaner completes successfully, but doesn't actually remove it.
So the verifier says it is okay yet it isn't working. The cleaner says it is removed but isn't.
1 - 10 of 10 Posts
Not open for further replies.