Tech Support Guy banner

Connected to wifi, PC says 'internet access' but can't browse internet

891 Views 4 Replies 5 Participants Last post by  sonzkitot
Hey everyone, sorry if this is in wrong area.

So today I bought a secondhand computer. It's a Toshiba Satelite L875D-S7230.

When I connect it to my home wifi it connects no problem and says 'internet access' when I hover over the icon. However when I open open google chrome or internet explorer and type in a site, it takes a little while then says this page cannot be displayed or this web page is unavailable.

The guy I bought it from says he had no issues. And I know it's not the internet because I'm using the internet to post this from phone.
I've tried a few ideas that worked for other people on other forums like using cmd box but to no avail.

Has anyone got any idea why the computer is being such a turd?? Can anyway give advice on how to fix the problem? Thank you all so much!
Not open for further replies.
1 - 5 of 5 Posts
Check if your Time/Date are correct to your computer. If not then fix that. Also disable any firewall on your computer and see if your problem fixed.
Is this a new install or "recovery to factory defaults" of the Operating System? If so, did you do it or did the seller and describe what else has been installed or updated.
Hello, it would also be helpful for you to provide the IP configuration of the machine at the time you are 'connected'. Also can you ping the public Google DNS? ( and

The Cleaver

Try this:

>Open Command Prompt (Administrator)
>Type "netsh winsock reset" (without quotes)
>Reboot and try to reconnect

1 - 5 of 5 Posts
Not open for further replies.