Tech Support Guy banner
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi,

Ok so, I'm having a bizarre situation with my XBox Live connection.

Even since I've introduced an Airport Extreme into my home network, my NAT type on XBox Live has been Moderate (this is not the problem, explained more later). This means I can play online, but sometimes different services don't work. It's worth mentioning that my NAT type was open when it was connected directly into my original router.

Now to some details on my network setup :)

The original router that I used before introducing the Airport Extreme is now acting as my modem (although, i've haven't strictly set this up manually). So although this router hands out 192.168.0.* addresses the NAT is redundant now as it's been replaced by the Airport Extreme. The Airport Extreme is hard wired into my original device and now acts as my router, handing out 10.0.1.* addresses.

When I noticed that my NAT type became moderate I went ahed and setup Port Forwarding for my XBox. Firstly, I setup a DHCP reservation for my XBox (controlled by the XBox MAC address), then I forwarded the XBox Live TCP/UDP ports to the reserved private DHCP address (which is 10.0.1.3).

The trouble is, after doing this I've not been able to connect to XBox live, so somethings going wrong somewhere. When I turn off the DHCP reservation for the XBox it connects fine.

Now, I've been troubleshooting for hours making sure that the MAC address of the XBox matches that in the Airport Extreme settings etc and everything is fine. This leads me to think that there's something wrong with my network setup, possibly due to having two NAT layers? Would this cause this problem? If so, how would I go about fixing this.

I hope I've explained this well :/

Thanks again,

P.S Sorry for the small novel.
 

·
Registered
Joined
·
2,298 Posts
Two routers means two layers of NAT. You need to setup the Airport Extreme as an access point instead of a router. From your router plug into one of the LAN ports not the WAN/Internet port on the Airport Extreme. Disable DCHP on the Airport Extreme. If you need to do any port forwarding, do it from the router connected to your modem.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
Two routers means two layers of NAT. You need to setup the Airport Extreme as an access point instead of a router. From your router plug into one of the LAN ports not the WAN/Internet port on the Airport Extreme. Disable DCHP on the Airport Extreme. If you need to do any port forwarding, do it from the router connected to your modem.
That really leaves most of the Airport Extreme features redundant, which is not what I want.

How would I setup the original router to act as a modem? and use the Airport Extreme as the router?

EDIT: Is it a simple a matter of turning off DHCP on the original router?

Cheers.
 

·
Registered
Joined
·
2,298 Posts
I'm not sure I understand the question. Is it a router modem combo that actually has a place to plug a phone line for DSL or connector for cable? If it's just a plain router then switch locations with the airport and configure the other router as I have explained. If it is a router modem combo then you should be able to turn off NAT all together.

And not it's not just as simple as turning off DHCP. Each time you plug a router into another router via the WAN port you a creating another network.
 

·
Super Moderator
Joined
·
82,234 Posts
If you want a modem/router combo to act as a modem-only you have to configure it that way. Often this mode is called "bridged." This is the same concept or feature to which srhoades referred as "turn off NAT all together."
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top