Tech Support Guy banner

CDROM drive not detected by computer

625 Views 5 Replies 4 Participants Last post by  Rollin' Rog
Well, a few days ago, I installed a new 128MB SDRAM chip into my HP Pavilion 6330. While this is not the source of my problem, this is when all the trouble started. Once the chip was installed and I restarted my computer, I noticed that there was no sound. I immediately checked in the "Device Manager" and found a conflict with my audio system. It turned out to be a resource conflict between my Nvidia Geforce 2 MX chip and the audio system. To solve this, I changed the resource of the audio system to a free space. Once this was done, windows told me to restart, which I did. This is where all the real trouble happened. After restarting, my computer would not go into windows. It would get stuck in the blue Windows 98 screen and would freeze up. I tried to shut down my computer and restart it, but the same thing would happen. I then went into safe mode and found that windows would load under it. After doing a system diagnosis, I found that the problem was my secondary IDE controller (Hard drive), so I disabled it, which solved the problem. Once I did that, windows told me to restart my computer again, which I did. After windows started up properly, I had two more problems which I still have no clue how to fix. My sound still does not work, which it has no resource conflicts this time, and of course, my computer does not detect my CDROM drive. It works however, since the cd "door" opens and closes fine, but windows does not detect it. When I restart my computer, windows shows a pop up message saying windows does not detect a CDROM drive. I have tried many different CDs to see if it is just a cd, but none work. The company, Hewlett Packard, knows less about computers it seems than a box of rocks. Its technical support, online and phone, doesn't help me at all. I checked in the "Device manager" and found that there is no controller installed for the CDROM drive either. I am stuck. Any clues?
See less See more
Not open for further replies.
1 - 6 of 6 Posts
Go to dos prompt and enter scandisc /resore there is a space between sacndisc and /restore

If this is no help try scandisk /restore.

i dont know much but i used this twice, once when I deleted explorer again when dvd rom driver wasnt detected.

happy new years.

Hope it helps
Sorry, I forgot to tell you, choose a date prior to all the problem you are having.
I think rstanley meant you could use a previous copy of your registry files by typing scanreg /restore at the "DOS Prompt Only" choice of the Startup Menu.
That might work and it has saved me a lot of time on numerous occasions.
But I can't see why more RAM would cause your problem in the first place. Maybe someone smarter will be along soon and have a better thing to try.
I tried it and it didnt work. The only date that was before the incident would say "failed to restore". Any other ideas?
Instead of disabling the secondary ide driver, have you tried removing it and let windows redetect and reinstall the drivers for it?

You may need to do the Bus Master drivers as well to do this.
1 - 6 of 6 Posts
Not open for further replies.