Tech Support Guy banner

CD works in DOS but not Win95

1069 Views 13 Replies 3 Participants Last post by  gilbco
I've looked everywhere but have not been able to figure this out: the machine is a Dell Latitude CPi, Samsung removable CD drive, Win95 OSr2. The CD drive used to work fine, then stopped for no reason I can see. When I load DOS drivers, it works in DOS; then in Windows, Explorer recognizes the drive as a CD, but cannot read a disk ('Drive not Ready..' etc.). If I boot without DOS drivers, Explorer sees the drive as some other kind of removable drive - the icon is different - and says the disk in the drive 'is not formatted - would you like to format it now?', which of course it then says it can't. In either case, Device Manager sees the drive with no problems, and says it is working as it should. The drive spins on bootup, and fn key drawer control works. There are no problems shown anywhere in Device Manager.
I've tried removing the drive from Device Manager, in normal and in safe mode, and having Windows reload it, with and without DOS drivers loaded; I've tried checking and unchecking disconnect, auto-insert notification, and DMA; I've tried removing the hard disk controller - the CD drive is on the secondary IDE - so Windows would reinstall it; I also tried disabling scsi1hlp.vxd (as suggested in one of the other threads here); and I've uninstalled suspect software (e.g., a 30-day trial CD ripper someone had installed & used). But the problem remains unchanged: works in DOS, not in Windows. The only variation I saw was that without DOS drivers and with DMA checked, the machine froze while loading Windows. Any ideas?
Not open for further replies.
1 - 14 of 14 Posts
Hi, gilbco, welcome to TSG....

Take a look in device manager under the hard disk controllers....on the third one down, look at the settings it set to 'default'?
Hi Candy - thanks for taking a look at this.
In device manager, the hard disk controller ('Intel 82371AB/EB PCI Bus Master IDE Controller') is set to default. The primary and secondary contollers listed beneath have no settings.
Try changing it to both ide channels enabled....reboot and see if that helps.

Click on Start-->Run.
Type in "regedit" and click OK.
Click on Edit--> Find.
Type in "noide" and click Find Next.
When it is found, make sure it is highlighted, then press the Delete key.
Press the F3 key to finish the search. Delete all references to noide.
Close the registry editor by clicking on the x in the top right corner.
Restart the computer.

Place the Windows95 CD-ROM Setup boot disk into the A: drive.
Turn the computer on, or Restart the computer.
When asked if you want to re-setup Windows, answer "N".
At the A:\ prompt, type "FDISK /MBR" and press enter.
Restart the computer.

Click on Start--> Programs--> MS-DOS Prompt.
Type "mem" and press enter.
If the Total Conventional memory is less than 640K, you may have a virus.
Please use a virus scanner/cleaner to try and remove the virus.
Type "exit" to go back to Windows95.
See less See more
Please don't try the Fdisk /MBR..... :(

Also, take a look in the device manager again.....are there yellow exclamation marks on the controllers? I don't think so from the sounds of it...but wanted to ask...
Ok ma'am, help me out so I dont do it again. Why not?
First off, we simply don't have enough information regarding his hard drive setup, etc. to 'rush' into this option....

Here is some reading material, while I don't agree with the beginning statement that it should 'never' be used, I believe it should be used with extreme caution and as a last option.

Some other information as well.....

And even with the NOIDE choice, we don't know yet if BOTH of these items occur....

32-bit file system access and 32-bit virtual memory are not available


Device Manager displays an exclamation point (!) in a yellow circle for the primary and secondary IDE channels

Of course, just my humble opinions ;)
See less See more
- Changed disk controller in device manager to both ide channels enabled, but it didn't change the problem.
- 'noide' was not found in the registry.
- I did try FDISK /MBR, but nothing changed.
- MEM reports 640K total conventional memory. NAV 2001 is run on this machine.
Device Manager shows everything fine, no exclamation points.
Alright, alright, I get the picture. Thanks. ;)
Gilbco, try this link for some helpful information:

The intel patch may be the answer for you.
Hi, I'm back again.
I checked the Intel pages - it took a while to find definite references to the right chipset family, and I admit I may have dozed off a couple of times reading, but I did find a thorough description of the Inf updater. I didn't install it, though, for a couple of reasons: 1) one user's guide said the utility was for desktops only and must not be used on a portable system (and the mobile version of this chipset - 440BX PCIset - was never really mentioned anywhere), and 2) the description of what the updater does suggests that it solves a problem that I don't have; if I understand correctly, it seems to say that it installs .inf files that point to the correct devices (rather than installing drivers or the devices themselves), and after installation, device manager will show that specific Intel devices - PCI Bus Master, processor to PCI bridge - have been loaded correctly without conflicts or exclamation points. This is already the case on my machine; at least I can now see that Windows is not loading the wrong thing.
One thing that confuses me is what it is exactly that identifies this drive as some other sort of removable drive. Device manager sees the drive and all of the controllers correctly, so I assume it's something else. I'm wondering if it's some kind of remnant of an old Iomega installation, which there apparently was at one time on this machine, or some other software that used the CD and never let go, if you know what I mean. Would there be anything to look for in the registry (besides 'noide')?
See less See more
Have we looked in the bios setup to be sure it isn't displayed as a removeable drive there?
Yes, I've checked it a few times, and also upgraded it yesterday - it always identifies it as a CD.
1 - 14 of 14 Posts
Not open for further replies.