Tech Support Guy banner

Can't ping certain sites

586 Views 0 Replies 1 Participant Last post by  TwistedRageFace
I came back from the weekend at my ma's and tried launching league of legends because that's my thing, whatever. When i did so though all i got was a RADS error saying that i could not connect to the http server. I went into cmd and tried pinging the website and got nothing, 100% packet loss. Some other sites work fine; i get instant response from tumblr and such. No idea what's up. Help pls, I'm crying. Q~Q

Basic info:Tech Support Guy System Info Utility version
OS Version: Microsoft Windows 7 Home Premium, Service Pack 1, 64 bit
Processor: Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz, Intel64 Family 6 Model 42 Stepping 7
Processor Count: 4
RAM: 4078 Mb
Graphics Card: NVIDIA GeForce GTX 560 Ti, 1280 Mb
Hard Drives: C: Total - 938661 MB, Free - 282823 MB;
Motherboard: Dell Inc., 0GDG8Y
Antivirus: Norton Security Suite, Updated and Enabled
Not open for further replies.
1 - 1 of 1 Posts
1 - 1 of 1 Posts
Not open for further replies.