Tech Support Guy banner
Not open for further replies.
1 - 1 of 1 Posts

· Registered
1 Posts
Discussion Starter · #1 ·
Hi. I use a linksys WUSB54G v4 wireless adapter to connect to my wireless network at home. I have done so in this way for at least the past year, without any major problems untill a few days ago, when it stopped working for no apparent reason. Usually I primaly use my connection to play Diablo2 or starcraft online, and it worked fine other then a little lag (which really is ridiculous for a 54 Mbps connection, but oh well) but the other day it stopped working. that night i had been playing D2 as normal with no problems. I left my computer on as i always did, leaving it doing a spybot scan. the next morning i got on my computer, deleted the problems spybot found (i looked through all of them, and they were all tracking cookies associated with internet explorer 6 or firefox 2, things that should not affect my connection) then all hell broke loose. when i tried to connect to, blizzards server said i couldnt connect because i was having connection issues or port 6112 was not open. In addition, i could not connect my stealthbot to, when i connected it started to go through the normal messages but stopped like so:
[BNLS] Connecting...
[BNLS] Connected!
[BNLS] Authorized!
[PROXY] Connecting...
[PROXY] Connected!
[PROXY] Request rejected or failed

The SBfix program, which connects the stealthbot to, had a more detailed summary of the connection:

Server Socket Listening:
Connection request: 320
2: Request:
2: Server Connected
2: Product: SEXP OldVB: CF NewVB: CF
2: Old MPQ: lockdown-IX86-13.mpq New MPQ: IX86Ver3.mpq
2: Closed
Connection request: 336
3: Request:
3: Server Connected
3: Product: SEXP OldVB: CF NewVB: CF
3: Old MPQ: lockdown-IX86-12.mpq New MPQ: IX86Ver2.mpq
3: Closed
Connection request: 328
4: Request:
4: ServerError: 10061: Connection is forcefully rejected
4: Closed

also, if i am persistent i can get it to successfully connect about once in every ten tries, tho it wont stay on for very long.

at this point i could still connect to the internet with a browser normally. after looking up some help online, i deleted the entries in my registry. after that i could connect to bnet, but after a few minutes i would be bumped off again, and this happened several times untill finaly it once again gave me the port 6112 error message. That very same day, my new housemate had set up a router of his own (could it be interfering?) so i switched to that one. I succesfully connected to bnet, however i am still bumped off every few minutes with the occasional 6112 error message. I updated my driver for the router, and it worked for a little while, then i was bumped off and got the 6112 error, only now i cant connect to my housemates network because the new interface does not accept WEP passphrases AND when i put in the hexadecimal numbers it says connected but i cannot access the internet at all. other than that, i only seem to have problems connecting to the game servers, and since i changed nothing that should affect the ports between when it worked and now i have no idea why it just stopped working. i have tried everything to make it work and it is really pissing me off! the first connection i used was a psk-tkip encrypted network, the second is WEP 128-bit. what angers me most is that this happened without warning or reason, and i really want to play my game! please help. also, i have noticed that, while it works fine when i first start up, if i leave the computer alone for extended periods, when i come back it will say it is connected but it will not be able to access the internet or anything untill i use the task manager to manually terminate the "network service" version of the svchost.exe processes. after that it works fine. i use Windows XP SP1, its firewall is disabled and i shutdown my zone labs firewall before i play, although sometimes if i leave that firewall running i will be able to connect to bnet without the 6112 error, but i still get bumped.

i just cleaned my registry, and it didnt help at all. i cant makes sense of this problem at all. the wierdest thing is how it will sporadically connect every once in a while- im not completely disconnected from 6112, but i get disconnected for some reason i dont understand.

please please help!
1 - 1 of 1 Posts
Not open for further replies.