Tech Support Guy banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all. This is my first post. I hope you can help.

I got a Canon MP600 (multi-purpose) for Christmas to replace my old Canon printer and scanner separates. I set up the machine itself according to the instructions, and had it working fine as a standalone. Then came the PC install ...

First off, the install CD wouldn't read very well. Undaunted, I went onto the Canon website and downloaded the MP drivers manually - they are actually a more recent version than the ones on the disc.

I ran the install and all seemed to be going OK. Several components popped up their "Found new hardware" wizards, and I followed them all diligently. One threw up an error, and said it had not installed correctly. I cannot remember exactly what it was, but I think it was something to do with a Bus and I think it was scanner-related, rather than printer-related.

Followed through the rest of the install, and tried testing. Printer was fine. When I went to scan, I could initiate a scan from the PC, but after scanning it could not return the scan data to the PC. I put this down to the failed install.

The problem is this ... I have uninstalled the drivers properly several times, and reinstalled them again each time, trying both the CD (which now reads OK, sometimes) and the downloaded drivers (uninstalling each time). However, on no occasion since the initial install attempt has the module which failed to install properly the first time tried to install itself again. There was a checkbox the first time saying "Do not tell me this again", but I'm sure I unchecked it.

If I cannot get this module to try and reinstall itself again, I do not know how to get the scanner going. I'm sure there is a flag somewhere (in the registry?) related to this, but how to find it?

Any advice would be appreciated. I've uninstalled and reinstalled so many times my heads spinning.

Thanks.
 

·
Retired Moderator
Joined
·
106,726 Posts
Control Panel, System, Hardware, Device Manager. Uninstall any devices in error and reboot. You should be prompted for the hardware again.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for such a quick reply. I should have said. I have already tried this. No devices were showing in error but I removed the obvious ones anyway and tried again. Still didn't ask for this device again.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top