Tech Support Guy banner

cannot read from floppy

3131 Views 13 Replies 4 Participants Last post by  eddie5659
OK here is the problem:

I need to copy files from a floppy to my documents, etc.

The computer is telling me that it cannot copy because it says
"The system cannot read from the specified device"

Under my computer i hit a: and it will show the files on the floppy, however, i cannot copy them to c:

I cannot unzip files from the a: using Winzip it says"
"severe error: cannot read file#1"

I just did a reformat of my hard drive and a clean install of Windows 98.
Not open for further replies.
1 - 14 of 14 Posts
Double-click My Computer. Double-click the A: drive. Right-click on the file you want to open, and choose Copy. Paste it to a location on your C: drive. Double-click on the file that you just pasted to your C: drive. What is the exact error message you receive?
I have done that. Right click etc. The error message says what I first posted.

Since I have reformatted my hard drive, would this be a driver problem as well? If so, how do I get a driver for a floppy drive that is part of the computer? Or is there something that tells the computer that the floppy is a read-only drive that I need to change? It will show the files on the floppy, Im just not allowed to copy them onto c:
Hello Jssch,

I know that you have already checked, but have you tried a different disk and/or made sure that the protect tab on the floppy is not locked? If so, go into device manager and expand the floppy disk controller heading. Click on standard floppy disk controller/properties/driver details. Is anything listed?

Is it recognising the floppies? If not, open up the case and have a look to see if any of the cables have come loose. If it has, or you're unsure, unplug it and push it back in.

The thing is, it may be getting stuck in the same directory, and that's the job of the 34th wire. Bit overtechnical, but it could be a problem.

When its in your directory, can you rightclick and choose Properties, to see if they're actually there.

Have a try of this. Pop your floppy in and go to Run and type a:
Now, it should come up with all the files. I'm thinking one of them, as its the files from the previous problem.

This will be on your desktop, so to speak. Try dragging the icon from the folder onto the desktop, or into another folder, say your My Documents.

Does that work?


See less See more
OK heres the situation as I see it now.

I can copy wordpad documents from a: to c:

But I cannot copy the files from Master Splitter or Winzip spanned disks.

When attempting to copy those files, I get the error" System cannot read from specified device."

can you not drag them into another folder, not using rightclick and going to copy?

when i drag them it goes into copy mode i think, so no, i cannot drag those files successfully.
You know earlier you said that you can copy wordpads.

Well, was this from the same floppy as the split files? Can you do an experiment to see if it'll allow the wordpads but not the split files?
Just split one, anything at all, to a smaller size, and stick a wordpad in on the same floppy as the split. See if you can drag both.

It seems to be moody. I cannot copy some files. I tried to copy a 400kb .exe file and got the same error message.

Would the reformat and reinstall of Windows 98 mean that I need to reinstall drivers, etc for the floppy drive?
Not usually. It just loads everything up from disks, etc.

I'm assuming that your floppy is ok. Just go to Control Panel | System. Device Manager. Look under floppy and see if there is a yellow !

What about trying my idea. The one where you have, say a wordpad and an exe file on the same floppy, and try copying or dragging.

Try a different floppy drive in your computer. Either use one that you know works, or buy a new one. Buy new floppy disks or borrow some that are working fine for friends. Copy and paste files from them.

Floppy drives do not use special drivers. Your problem is not a driver issue. It also is not very likely to be a Windows problem. Reinstalling Windows would be a waste of time. It's either a bad floppy drive, bad floppy disks, or corrupt files.
OK I fixed my problem. I just dont know why it was a problem. Ill explain what I did and maybe someone can tell me why it was causing a problem so I dont do it again.

Under the start menu on Windows 98 I was logged on as such and such.

When I logged off, the floppy drive began allowing me to copy the files.

Glad its working. Could be a dodgy .pwl file. Hmmm....

1 - 14 of 14 Posts
Not open for further replies.