Tech Support Guy banner

Can only connect to Google? DNS Maybe?

4593 Views 4 Replies 4 Participants Last post by  CoolBurn
Hi! So this problem started occurring yesterday, and it's been very on and off, and seemingly random.

When it occurs, I can usually only connect to google, and I can even do searches but I can't connect to ANY other website. When I try to load other sites, it says Resolving Host... on the bottom left corner of my browser (Chrome).

I've tried Googling it and so far I've found no solution to fix my problem. The thing is, my internet is fine right now but I know the problem will come back again, so I'm not sure what makes it occur.
Not open for further replies.
1 - 5 of 5 Posts
you could try using google open DNS

anything changed on the system at ?
anything new

Google public DNS
Note using google public DNS servers from outside the US may actually slow performace - so use the following as a test to identify DNS issues - if these resolve the issues , then we need to investigate further to optimise the use of DNS

Google public DNS

Theres also a link on how to setup those DNS IP address up on a PC

Then once you have set up those DNS entries

Flush & register DNS

Hold the Windows key and press R, then type CMD then press Enter to open a command prompt box (A new dialogue box - black with white font, will appear on screen ):
In the command prompt window that opens, type the following commands:


If you receive the message
The requested operation requires elevation.
Then please open the command prompt as administrator
Start> All Programs> Accessories and then right click on Command Prompt, select "Run as Administrator" to open a command prompt.

now type the command again

I have found these to be a useful tools to use for DNS testing
See less See more
No, there's nothing new on the system at all since the problem began.

I'm going to try all of those when the problem comes up again, thanks. I'll get back to you to see if it works out
This may not solve the problem for everyone but i have a simple solution for this that worked for me and doesn't require DLing a bunch of unfamiliar programs. Simple explanation is most sites still use IPv4. Sites like Google Youtube Facebook and many other very popular sites have already started using IPv6. If you find that you can connect to sites like these and no other sites you probably have a problem with your IPv4 settings. I'm using Win7 so I'll leave instructions for that but I'm sure you can figure out the steps on other versions.


2)Once on NETWORK AND SHARING CENTER page click on CHANGE ADAPTER SETTINGS (toward top left portion of page)

3)Find the connection you use on the NETWORK CONNECTIONS page (<-the page that pops up) RIGHT CLICK on your connection and choose PROPERTIES.

4)In the popup window on the NETWORKING tab you will see a list of checked boxes with script next to them. Find the one labeled INTERNET PROTOCOL VERSION 4 (TCP/IPv4)

5)Highlight the text (single left click) and click the PROPERTIES button (middle right on page)

6)On the PROPERTIES page under the GENERAL tab you will want to make sure the bubbles next to OBTAIN IP ADDRESS AUTOMATICALLY and OBTAIN DNS SERVER ADDRESS AUTOMATICALLY are both checked. (the top bubble for ip and top bubble for dns should both have a dot)

7)Push OK/APPLY on all windows as you back out of these options and repeat these steps for all connections on the NETWORK CONNECTIONS page.

8)Restart computer/router/browser as necessary but this should fix the problem instantly.
See less See more
Just to add:

Open Chrome, in the URL type: chrome://flags (press enter)
Scroll down until you see &#8220;Async DNS Configuration&#8221; mark it as Disabled.

Next in the URL type: chrome://net-internals/#dns (press enter)
Click on the Clear host cache.

Close the tab and try the internet again.
1 - 5 of 5 Posts
Not open for further replies.