Tech Support Guy banner

behind a linksys w/wireless dlink pci card

2455 Views 7 Replies 5 Participants Last post by  gcollins
I'm behind a linksys (befw11s4) wireless access point router. I just bought another wireless pci adapter for another computer in my home and the only brand they had was D-link and I was told it wouln't be a problem. They are both 802.11b, but I have not been able to get a solid connection. Once I am connected I am just booted off again and told that there isn't even a wireless network available. I sat on the phone forever with the D-link people and they didn't help one bit, actually I think I'm worse off now. It seems like I've tried everything that I can. Any ideas???
Not open for further replies.
1 - 8 of 8 Posts
What is the model # of the Dlink card you have?
its a dwl520+, sorry I missed that.
It's also on a pretty small and slow machine. An emachines w/celleron 800 mhz, so could I possibly need to update the bios? I'm not familiar with the computer so I don't really know what updates have been done to it.
The speed of the machine has no bearing on the connection, I'm sure that's not the issue.

I'd move the machine right next to the WAP and see if you can get them working. I've noticed that my laptop with either the Zoom or the SMC wireless PCMCIA card doesn't have a lot of range. I also have an SMC USB wireless with the dual antennas, it has a much better range.

Basically, I think you need to eliminate the wireless issues from the problem by getting next to the WAP, and then debug the driver/connection issues.
I've used a 520 series card and have talked to Dlink about it. They have SERIOUS problems with their older drivers and I've found that even installing the newer drivers does not help the situation. In some cases the older drivers need to be COMPLETELY removed before the new drivers are installed or the problems will continue.
In one case I just gave up and reinstalled Windows and the new drivers and everything worked fine - a drastic measure, i know, but I had spent hours on the problem already....
I also have the same problem. I know the D-link card works because I used a dlink router and it had a 90 percent connection. I switched to a linksys router and now it won't connect to it.

I may have to return my dlink card and get a linksys one, but I hope I don't have to do that.
Did anyone find a resolution to this problem. If so please post.

Thank you,
1 - 8 of 8 Posts
Not open for further replies.