Tech Support Guy banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
425 Posts
Discussion Starter · #1 ·
Hey
I just got BF2 again and it runs Beautifully... All Highs at 1280x1024 80fps. BUT my sound stinks... whenever ingame, ANY game the sound will "pop" quite frequently. Sounds kinda like static. it does not do this when playing music via itunes or anything like that, only when playing games. Also every time the sound pops, (very frequently) BF2 will glitch and this makes it kinda unplayable. it runs great, but it glitches all the time... your help is appreciated!!
 

·
Registered
Joined
·
425 Posts
Discussion Starter · #3 ·
well i was using the integrated sound, but i found a old soundblaster in my dads closet and the game runs better. it sounds weird but it runs flawlessly after about 3-5 mins. it runs really glitchy then just stops and run great. i can live with this but it would be nice to have no glitchyness :) Thanks
 

·
Registered
Joined
·
2,113 Posts
Do I understand your system specs correctly in that your running a somewhat mid-high end rig on a 400 watt Comp USA power supply? If that is correct you need to replace that inadequate power supply regardless if it fixes anything or not.

Also you should put another gig of ram in your setup if you want Battlefield 2 and other newer games to run smoothly.
 

·
Registered
Joined
·
425 Posts
Discussion Starter · #5 ·
the PSU could be a problem, but how do you explain after running for 2-3 mins the game runs perfect at a constant 70-80 fps? My dad has a 450w PSU in his office i could try, but mine is doing fine for now so i don't need to spend any money at the moment... i'm only 16 and i just spent 500 bux for the new system. And yes you understand it quite well. It is a 400watt from compusa!!
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top