Tech Support Guy banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
ive been playin call of duty for a long while now with my ati radeon 9500 pro. i recenty got the 9800 pro and its extremly laggy. also, i have updated drivers... so whats the problem. i have an hp 512 mb 60 gb
 

·
Registered
Joined
·
1,124 Posts
What do you mean by laggy? Like as in choppy? and is this the only game that does this? Is it an online game? If so what is your ping? YOu can also check your FPS; see what they are and let me know. PLUS has it always been "laggy"? If not when did it start happening?
:)
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
yes choppy. it hasnt always done this and its the only game i play so i dont know about others. and it does in sp and mp. i have dsl and i know its not my connection. its something with teh card. it worked fine with my 9500 pro. but it messed up with the 9800 pro
 

·
Registered
Joined
·
14,017 Posts
Did you remove the drivers before you changed the card? Also before shutting down did you remove the 9500 from device manager?

That is the order which you should do it. I had a 9800XT and an X800XT both showing in device manager for a few minutes because I did backasswards. That is why I asked.;)
 

·
Premium Member
Joined
·
52,926 Posts
And make sure the power connector to the side of the card is connected, I've been informed that some cards will run without it but not perform up to spec.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top