Tech Support Guy banner
Not open for further replies.
1 - 1 of 1 Posts

2 Posts
Discussion Starter · #1 ·
Hello Everyone,

Recently my M2N-E all of a sudden stopped POSTing and gave me a blank screen. I used it everyday to do light computing and school work. My computer was on when a power outage caused by someone using an electric (power) saw. I turned the computer back on a few hours after the power went back on and everything seems to work fine as usual. I left it running on the internet while making a quick trip to school to turn in some paperwork. When I returned, the computer just hangs there. The LED on the USB mouse wasn't on either. So I pressed the reset button to restart the computer, but it won't POST, just a blank screen. When I press the power button to turn it on, the CPU and case fans spin but computer just hangs there and the red HDD LED lights up without blinking.

I've been using this computer since February 2009 when I received this board as an RMA and it worked 100% until now.

This is what I've tried:

Power on with one RAM and video card
Take the motherboard out of the case and powering it on a cardboard box (w/ CPU, one stick of ram, and VGA card of course)
Borrowed a friend's 500w PSU from his gaming rig to try on my system, but still no go

Every computer part was tested and confirmed to be working on my friend's computer except for the motherboard and CPU because he has Intel :(

Please help me troubleshoot this problem as I really need this computer for school.

Here are my specs:
M2N-E bios 1601
Athlon64 3500+ (ADA3500IAA4CN)
Crucial 2 x 1 GB dual memory
Sapphire X300SE 128MB
Hitachi 250GB HD SATA
Generic 300W PSU
D-Link Wireless PCI card
Windows 7 32-bit

Thank you for reading. Sorry for writing too much and my bad English. English is my 3rd language. If I missed any information please don't hesitate to ask. Any help would be greatly appreciated.
1 - 1 of 1 Posts
Not open for further replies.