Tech Support Guy banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
I bought an HP Pavilion about a year and a half ago. It uses 32-bit Vista Home Premium using Service Pack 1. I am just now getting around to bringing it up.

I have had problems while installing some of my applications because I apparently do not have full administrator access. I only set up one account and did not enable the Guest account.

I searched this forum section and came across a thread started by MSATHER on August 11, 2009 and tried the things suggested by TheOutcaste in Msg #20 of that thread. Here's what I found out so far:

1. My command prompt window is titled simply "Command Prompt", not "Adminstrator: Command Prompt".

2. I can run regedit. That, and #1 above, indicate I am logged on as a Built-In Administrator.

3. When I run regedit, Windows does ask for permission, so apparently UAC is enabled on my system.

4. The key ConsentPromptBehaviorAdmin has a value of 2 (Prompt to Continue)

5. The drop-down history list in the Run dialog is always blank, even though I've installed things from there before and even though I've run regedit. I'm unsure of the significance of this.

6. When I open a command prompt and type "vssadmin List ShadowStorage" <Enter>, I get the "Error: You don't have the correct permissions to run this command. Please run.." message.

7. When I then type "AT" I get an "Access is denied" message. In Message #20 of this thread, this tells me I am running from an "Administrator" account (as opposed to a "Built-In Administrator account).

8. If I did this from the Built-in Administrator account (which I assume I am, according to the results given in #6 and #7 above) and ShadowStorage would be listed, and all tasks scheduled using AT would be listed, or a message that there are no entries in the list would be displayed. They aren't.

9. When I type net user <name> at the command prompt I get:

User name (it's the right one)
Full Name (it too is the right one)
Comment
User's comment
Country Code 000 (System Default)
Account active Yes
Account expires Never

Password last set 8/24/2009 12:38:30 PM
Password expires Never
Password changeable 5/3/2008 12:38:30 PM
Password required No
User may change password Yes

Workstations allowed All
Logon script
User profile
Home directory
Last logon 8/30/2009 9:24:36 PM

Logon hours allowed All

Local Group Memberships *Administrators
Global Group memberships *None
The command completed successfully.

I'm asking for help because in the process of installing and configuring my applications, Vista tells me I don't have administrative privileges (or similar words) and I do need them in those cases.

Where do I stand and how can I overcome the problem?
 

·
Registered
Joined
·
7,889 Posts
Here is some good advice when installing programs in Vista, This is good advice even if the program was designed for Vista.

Here is how to install software or drivers on Vista that are for XP,2000,NT4,98,95

1. Download your program to a folder of choice, Right click on the setup.exe file for the software/driver you are trying to install and select properties, if there is an "Unblock" button on the General Tab, click it, then go to the compatibility Tab

2. Tick the "run this file in compatibility mode" box and then select XP, or whatever OS the software was designed for, in the drop down box, Tick "run as Administrator" if it is available, hit OK. If it was designed for Vista then skip compatibility and only use run as administrator.

3. Now double click this setup.exe file to execute the install process, hopefully all will go well and install the drivers/Software you need.

4. If the exe installs software for the device, or you have installed software only, you need to navigate to the program folder where it installed, then do the compatibility thing (1 & 2) again for the program executable(s). If the program was designed for Vista skip compatibility mode, just tick "run as administrator"

I do not guarantee all drivers or software to work in Vista, but a large percentage do..

Good luck.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top