Tech Support Guy banner

Admin privilage error

890 Views 4 Replies 2 Participants Last post by  MayhemDas
I recently recieved a copy of Command and Conquer Generals for the holiday. I was able to intall it fine, but when it asked me if I wanted to start it, I said yes, and recieved the error message that "I needed to log in with administrator privileges and try again".
I am the computer admin, thats how I was able to install the game. This game is made by EA and I also purchased another game by EA which I have had no problems with.
So, I went in and made sure that I had all the privilages, and I did. I went in through safe mode, logged in as the admin, and checked the security of this game and made sure I was clear there. I also tried the "run as" button by right clicking on the icon, and selected admin, but still no go. I returned the game in exchange for another copy thinking that this might be something that was wrong with the cd. The new copy is giving me the same problems. I am now pretty sure it is something wrong with my PC or at least the way this particular game is seeing my PC. I also tried running it with my Norton turned off. I am almost positive this game does not need access to the internet to play but I also cleared it through my firewall. This is a home PC running XP.
Now I am just frustrated, lol. I have been cruising the net for solutions to this error and have asked a number of people what they think. Most are stumped. I havent gotten any idea where to go from here. I came across this site from a google browse of the error, which led me here. There was a match with the word administrator but that was it.
Any Ideas? Thank you in advance for any help you can offer in this matter.
See less See more
Not open for further replies.
1 - 3 of 5 Posts
Not only do they not have it listed, but when I called them they had little help to offer on their tech support line. They thought that maybe the sound card was interefering, but I dont see how only this game would have that problem or how the sound card would make the pc think I am not the admin. I'll show it whose the admin!!!
This issue was resolved. Thank you for you time with this. The resolution came when I
Put the first disc for the game into the cd drive.
Open my computer
Right click on the cd and select browse or explore
Locate the secdrv.sys file, right click on it and select copy
Browse into the hard drive that has windows installed
Open the windows folder
Open the system32 folder
Open the drivers folder
Go to the edit menu and paste the file into this folder

I hope this can help anyone else who finds a similar problem. And yes I did get zero hour too. It was a deluxe pack
See less See more
1 - 3 of 5 Posts
Not open for further replies.