Tech Support Guy banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
My husband added a 2nd hard drive to our computer, and since then, we've had issues with our CDrom drive. For awhile, it would just throw fits sometimes, like not opening or not reading a disc. However, now we can't get it to open at all. The light comes on and it makes noise like it's going to open, but it doesn't. Any suggestions? Oh, and I tried reinstalling drivers already but that didn't work.
 

·
Registered
Joined
·
1,693 Posts
It may be a master/slave thing.Is the 2nd h/d slaved to the cd? Or is it on the other h/d ide channel?
 

·
Registered
Joined
·
736 Posts
Hi,

Barfly probably has hit upon your problem. Here is a little chart that might help you fix it:


The master and slave jumpers must be set up correctly on your drives as displayed on the top of each drive.

DO NOT mix master and slave with CS (cable select) on the same ribbon cable. If one is Master the other MUST be slave. If one is Cable Select the other one on the same ribbon cable must be Cable Select. (Please note that the majority of hard drives are factory default as Cable Select)

Make sure the drive is placed correctly on the ribbon cable as shown below:

M
O
T
H ==Ribbon Cable=== Slave ===Master (end of cable)
E
R ..................................„» OR „º
B
O == Ribbon Cable==Cable Select==Cable Select (end of cable)
A ..............................( as Slave)……. ( as Master)
R
D


Ribbon Cables and colors of 80 pin cables look and are to be used like this:

Motherboard============Slave==============Master
………......Blue………..........….……..Gray………................…………Black
.
Make sure a master is always present, because you can not run a slave without a master.

Cables must be the 80 conductor cables for hard drives and never any more than 18” long.

If you try cable select and that does not work, give the master/slave setting a try. Conversly, if the master/slave setting does not work, give the cable select setting a try.

A friend recently told me that with Western Digital if it is the only drive on the cable, the jumper will need to be removed ( try removing the jumper and connect the drive by itself on the IDE channel ) I don’t use Western Digital drives, so I can’t verify this, but might be worth a try

Please note thatt the floppy cable red mark is put on opposite as the regular hard drivers. Otherwise, the red mark faces away from you as you work in the case or you could say it faces the power source for the drive.

Please let us know if you have other questions or need more assistance.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #4 ·
My husband double checked everything to make sure, and it seems to be set up right. It just started working again by itself last night, hopefully it stays working! Thanks for your responses
 

·
Registered
Joined
·
736 Posts
Hi,

Glad to hear you got it going. If your husband checked it, bet you had a loose ribbon cable or something like that.....he may have moved it enough to make a better connection. Anyway, enjoy it while it works.
 

·
Registered
Joined
·
728 Posts
A sticking tray is a hardware problem inside the drive. Something inside the drive is causing it to stick and not allow the drive to open freely. This is a very common problem with cd drives. The only way to fix it is to open the drive and find out where its hanging up. FYI they are a pain to open and if its a newer drive it will void any warranty.

If for any reason in the future the drive fails to open. Look at the front bezel of the drive and see if you can find a little pinhole. Using a paperclip or a very small hex wrench. Place the clip/wrench in the hole and push it in. This will force the cd tray to open.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #7 ·
Well, the problem is starting again! But now I'm having a whole mess of problems with other things on my computer as well, and I'm pretty sure they all have to do with one another. I would appreciate it if someone would take a look at my other post, and maybe give some suggestions...I'm lost as to what to do!

http://forums.techguy.org/showthread.php?t=272152

Thanks bunches.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top