Tech Support Guy banner
  • Please post in our Community Feedback thread for help with the new forum software! If you are having trouble logging in, please Contact Us for assistance.
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter · #1 ·
Hi, I've set up a wireless ad-hoc network between two laptops. The host laptop has an ethernet connection to the net through a router. The second laptop connects to the net through the host laptop over the wireless ad-hoc network. It all works perfectly until either of the laptops goes into standby.

When both laptops connect up again the host laptop connects to the net no problem but the non-host laptop can't connect to the internet through the host. Both laptops are actually connected because I can access the non-hosts laptops shared folder and vice-versa.

The only way to fix this is to restart both laptops and then it works perfectly again.

Both laptops are running XP Pro SP3.

Hope my explanations not too confusing! Anyone any ideas, please!:)
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #2 ·
Here's some extra information, I've done the nbtstat -n, ipconfig /all thing on both laptops when everything is ok then again when the internet connection ****s-up.

Host laptop when everthythings ok

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Mark>nbtstat -n

Marks wireless net:
Node IpAddress: [192.168.0.1] Scope Id: []

NetBIOS Local Name Table

Name Type Status
---------------------------------------------
MARK <00> UNIQUE Registered
DOMA <00> GROUP Registered
MARK <20> UNIQUE Registered
DOMA <1E> GROUP Registered

Marks Wired net:
Node IpAddress: [10.0.0.2] Scope Id: []

NetBIOS Local Name Table

Name Type Status
---------------------------------------------
MARK <00> UNIQUE Registered
DOMA <00> GROUP Registered
DOMA <1E> GROUP Registered

C:\Documents and Settings\Mark>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : MARK
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : Yes
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Marks wireless net:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : 11a/b/g Wireless LAN Mini PCI Adapte
r
Physical Address. . . . . . . . . : 00-05-4E-48-64-F4
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.0.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Ethernet adapter Marks Wired net:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Mobile Connecti
on
Physical Address. . . . . . . . . : 00-0D-60-75-A4-D1
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 10.0.0.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.0.0.138
DHCP Server . . . . . . . . . . . : 10.0.0.138
DNS Servers . . . . . . . . . . . : 10.0.0.138
Lease Obtained. . . . . . . . . . : 16 September 2008 17:36:52
Lease Expires . . . . . . . . . . : 26 September 2008 17:36:52

C:\Documents and Settings\Mark>
Non host laptop - everything ok

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Petra>nbtstat -n

Wireless Network Connection:
Node IpAddress: [192.168.0.118] Scope Id: []

NetBIOS Local Name Table

Name Type Status
---------------------------------------------
PETRUNKA <00> UNIQUE Registered
PETRUNKA <20> UNIQUE Registered
DOMA <00> GROUP Registered
DOMA <1E> GROUP Registered
DOMA <1D> UNIQUE Registered
..__MSBROWSE__.<01> GROUP Registered

Local Area Connection:
Node IpAddress: [0.0.0.0] Scope Id: []

No names in cache

C:\Documents and Settings\Petra>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : petrunka
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : mshome.net

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . : mshome.net
Description . . . . . . . . . . . : Broadcom 802.11b/g WLAN
Physical Address. . . . . . . . . : 00-21-00-29-19-CC
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.118
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 192.168.0.1
Lease Obtained. . . . . . . . . . : 16 September 2008 17:38:39
Lease Expires . . . . . . . . . . : 23 September 2008 17:38:39

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connecti
on
Physical Address. . . . . . . . . : 00-1E-EC-75-00-B2

C:\Documents and Settings\Petra>

Host after the connection ****s-ups.

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Mark>nbtstat -n

Marks wireless net:
Node IpAddress: [192.168.0.1] Scope Id: []

NetBIOS Local Name Table

Name Type Status
---------------------------------------------
MARK <00> UNIQUE Registered
DOMA <00> GROUP Registered
MARK <20> UNIQUE Registered
DOMA <1E> GROUP Registered
DOMA <1D> UNIQUE Registered
..__MSBROWSE__.<01> GROUP Registered

Marks Wired net:
Node IpAddress: [10.0.0.2] Scope Id: []

NetBIOS Local Name Table

Name Type Status
---------------------------------------------
MARK <00> UNIQUE Registered
DOMA <00> GROUP Registered
DOMA <1E> GROUP Registered

C:\Documents and Settings\Mark>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : MARK
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : Yes
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Marks wireless net:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : 11a/b/g Wireless LAN Mini PCI Adapte
r
Physical Address. . . . . . . . . : 00-05-4E-48-64-F4
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.0.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Ethernet adapter Marks Wired net:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Mobile Connecti
on
Physical Address. . . . . . . . . : 00-0D-60-75-A4-D1
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 10.0.0.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.0.0.138
DHCP Server . . . . . . . . . . . : 10.0.0.138
DNS Servers . . . . . . . . . . . : 10.0.0.138
Lease Obtained. . . . . . . . . . : 16 September 2008 17:36:52
Lease Expires . . . . . . . . . . : 26 September 2008 17:36:52

C:\Documents and Settings\Mark>

Non-host after connection ****s-up.

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Petra>nbtstat -n

Wireless Network Connection:
Node IpAddress: [192.168.0.118] Scope Id: []

NetBIOS Local Name Table

Name Type Status
---------------------------------------------
PETRUNKA <00> UNIQUE Registered
PETRUNKA <20> UNIQUE Registered
DOMA <00> GROUP Registered
DOMA <1E> GROUP Registered

Local Area Connection:
Node IpAddress: [0.0.0.0] Scope Id: []

No names in cache

C:\Documents and Settings\Petra>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : petrunka
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : mshome.net

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . : mshome.net
Description . . . . . . . . . . . : Broadcom 802.11b/g WLAN
Physical Address. . . . . . . . . : 00-21-00-29-19-CC
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.118
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 192.168.0.1
Lease Obtained. . . . . . . . . . : 16 September 2008 17:38:39
Lease Expires . . . . . . . . . . : 23 September 2008 17:38:39

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connecti
on
Physical Address. . . . . . . . . : 00-1E-EC-75-00-B2

C:\Documents and Settings\Petra>
 

·
Retired Moderator
Joined
·
106,726 Posts
Try checking the adapter characteristics in Device Manager for each machine and disabling any power saving options. This may or may not help, but it's one thing to try. Obviously, I'd also visit the manufacturer's website and download/install the latest wireless driver.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top