Tech Support Guy banner
  • Please post in our Community Feedback thread for help with the new forum software! If you are having trouble logging in, please Contact Us for assistance.
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
We're having difficulty with a large data file of 4 million records in Access 2000. We can't delete records after it has been linked. Also, when opening an unlinked database, it automatically links it.

error: operation not supported by this ISAM.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Originally posted by Dreamboat
Does this help?

http://support.microsoft.com/support/kb/articles/Q243/4/66.ASP?

Have you repaired and compacted lately?
This issue comes from someone in one of our Remote locations. I know he hasn't tried to repair & Compact. I saw the article above but he is a novice and couldn't perform the task. Question - If you compact, can you later delete a record?
 

·
Registered
Joined
·
941 Posts
Yes. Repair and compact simply removes blank space inside the file and helps to restore corruption, including indexes, which I suspect is where your problem may lie.

I don't fully understand your post; are all related files Access files? What do you mean, "when opening an unlinked database, it automatically links it"? There are only two scenarios that I know of, whether the front and back ends are Access or not: either you open with the AutoExec, startup, and code options intact, or you don't. Have you tried opening the offending self-relinking mdb file from inside Access, while holding down the shift key (bypasses the aforementioned options, where no security is applied)?
 

·
Registered
Joined
·
12 Posts
I don´t know if this works for you, but try to locate the key "maxlocksperfile" on your registry and modify to more than your records on the table. Some times i have been this problem with large databases. I usualy use 99999999
after that reboot your machine
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top