Tech Support Guy banner

8gb out of 16gb physical memory available

361 Views 1 Reply 2 Participants Last post by  Oddba11
Tech Support Guy System Info Utility version
OS Version: Microsoft Windows 10 Home, 64 bit, Build 18363, Installed 20200209204531.000000+120
Processor: Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz, Intel64 Family 6 Model 94 Stepping 3, CPU Count: 8
Total Physical RAM: 8 GB
Graphics Card: NVIDIA GeForce GTX 1060 6GB
Hard Drives: C: 460 GB (200 GB Free); D: 931 GB (532 GB Free);
Motherboard: Gigabyte Technology Co., Ltd. H110M-S2H-CF, ver x.x, s/n To be filled by O.E.M.
System: American Megatrends Inc., ver ALASKA - 1072009, s/n To be filled by O.E.M.
Antivirus: Windows Defender, Enabled and Updated

I have two kingston 8gb RAM sticks in my PC. it has always worked, for 6 years straight. Out of nowhere i have 8gb RAM according to the following: Windows info, BIOS, CaniRunit. But Speccy tells me i have two 8gb installed, but 8 available physical ram (as seen below). I took out both sticks one by one and put them in the other while rebooting. Both sticks are fully operational, and so are both slots.

I tried to clear the CMOS, don't know if it worked. (i dont have a jumper so i used a paperclip)
This problem is out of the blue, i don't know what caused it. This might as well have been going on for weeks, i dont game all that often anymore so i didn't really notice anything wrong until i saw it in task manager.

if anyone knows a solution or something to try, PLEASE do say. I'm out of ideas.


Memory slots
Total memory slots 4
Used memory slots 2
Free memory slots 2
Type Unknown
Size 16384 MBytes
Channels # Single
DRAM Frequency 1066.5 MHz
CAS# Latency (CL) 15 clocks
RAS# to CAS# Delay (tRCD) 15 clocks
RAS# Precharge (tRP) 15 clocks
Cycle Time (tRAS) 36 clocks
Command Rate (CR) 2T
Physical Memory
Memory Usage 49 %
Total Physical 7.95 GB
Available Physical 3.99 GB
Total Virtual 21 GB
Available Virtual 15 GB
Number Of SPD Modules 2
Slot #1
Slot #2

^Notice how it shows two slots are full, slot #2 disappears when i take one stick out
See less See more
Not open for further replies.
1 - 2 of 2 Posts
If the BIOS isn't seeing it, Windows won't either.

I noticed they are running in single channel ( Channels # Single ). I'm not familiar with speccy, but RAM usually runs in dual channel mode. Which would lead me to believe the sticks in the wrong slots. The motherboard User Manual should cover which slots are to be used when two sticks are being used.

As for the BIOS, aside from the jumper, you can simply enter the BIOS and choose "Restore to factory default", save, and exit. After the reboot, reenter the BIOS and ensure all of your settings are correct.

You could also power off, remove AC power, and try removing and reinserting both RAM sticks (or even swapping positions).
1 - 2 of 2 Posts
Not open for further replies.