Tech Support Guy banner

2 b450 mobos possibly dead on arrival

664 Views 14 Replies 5 Participants Last post by  managed
So long story short, i just got 2 new b450 tomahawk mobos(one for me, another for a friend) and i tested them both with my ryzen 3 1200. Problem is none of them want to boot. I can't even get a fan spin. The only thing that works is the bios flashback button which causes an led to light up when i press it. Please help
Not open for further replies.
1 - 15 of 15 Posts
In order to help you, you need to post ALL of your exact system specs. Along with the motherboard, you need to post the exact ram you used, exact pw supply, exact video card, etc, etc, etc.

Next have you read the guide at the top of the forum for problem builds? If not, do so.

I tend to think it is something you are doing, mismatched parts, etc. The odds of two consecutive DOA boards are VERY high. With all of the systems I have built [over 500] I have had one DOA board.
You are not by chance attempting to use the onboard port on the motherboard are you?
Ryzen 3 1200
8gb of ddr4 @3000mhz
Evga 850 watt psu gq 80+ gold

And no im not using an on board port.
But even if i was, that wouldn't explain the lack of fan spin.
I made sure to check if i put in the essentials (24 pin for mobo and 8pin cpu pwr for the cpu)
Read the guide and follow the procedure outlined. If you follow ALL of the steps, you will find the cause of your problem.
If you are sure the 4/8/12 aux pw connector is plugged in, I would guess you do not have the board mounted correctly. Did you do an out of case build prior to installing the board in the case?
I did it all outside of the case, on the motherboard's box
OK, you are not answering the question. Did you read and follow ALL steps of the guide?
Getting two DOA motherboards in a row is just about impossible. As I said out of over 500 builds, I have had 1 dead motherboard.
Here's a few images of my current setup
(Psu: corsair cx 430, ram: 8gb @2400mhz ballistix)


See less See more
And yeah i have read it
I also tried using my gygabyte rx 570 on the mobo and still nothing.tried to put the ram in all slots as well
Using a cx pw supply in anything other than a very basic build ie onboard/onchip video, is just asking for a problem. Even corsair says the cx or vs series is for a basic system.

If you follow ALL steps of the guide, you will find the cause of your problem.
I also tried an evga 850 watt gq on this earlier. Didn't do anything either. Ill read the guide again to see if i missed anything
Aand it worked.
Im stumped. I did a whole bunch of randok stuff and it worked
Nvm i turned it off and went to get a monitor and i get the same problem again.
Is there something I may be doing wrong here?
I hope you are not trying to start it with the heat sink off like in the pictures.
I hope you are not trying to start it with the heat sink off like in the pictures.
I was thinking the same thing
You have to remove the 2 black plastic brackets with the silver screws then attach the heatsink and fan with it's 4 screws going through the board and into the metal plate under the board.
Font Parallel Circle Drawing Auto part
See less See more
1 - 15 of 15 Posts
Not open for further replies.