Tech Support Guy banner

Discussions Showcase Albums Media Media Comments Tags

1-5 of 5 Results
  1. Hardware
    I am building a pc for the first time and believe everything is put together correctly however, there is no display reaching the monitor, none of the fans turn on (gpu, cpu, and peripheral) and the cpu red light turns on, then switches to the vga light after a few seconds. I know the motherboard...
  2. Hardware
    hi my motherboard's red vga light stays on all the time, i tried reseating the gpu but it didnt work. my mobo model is aorus z390 pro wifi.
  3. Hardware
    Hey everyone, few days ago I built a new pc: Mobo: Aorus b560m pro ax Cpu: Intel 11400f Psu: Seasonic 650w Ram: 2x 8gb , A2,B2 config Gpu: Used Gtx660ti So everything is plugged in and powered up (2x6 pin to gpu), gpu connected using hdmi. I turn on the PC I get no signal on the screen and...
  4. Hardware
    I have a cyberpower pc, with an msi b150m bazooka motherboard with an i5 and radeon rx480 graphics card and 2 patriot viper 4gb ram. I took both ram out to check the model number and reseated them, when I turn on my computer, I see the ez debug light turn on on my motherboard with vga. It starts...
  5. Hardware
    Building for a friend and stuck Maximus VIII Hero i7-7700k Teamgroup tforce vulcan 2x8gb (TLGD48G2400HG14BK) EVGA Geforce GTX1080 Hard drive + ssd etc.. Built system and tried booting. During post the mobo 'VGA led' turns on upon hitting code 62 (yes 62), then briefly flashes code 72, then...
1-5 of 5 Results
Top