Tech Support Guy banner
  • Please post in our Community Feedback thread for help with the new forum software! If you are having trouble logging in, please Contact Us for assistance.

Discussions Showcase Albums Media Media Comments Tags

1-20 of 45 Results
  1. Hardware
    Hi everyone! I have a Lenovo Thinktank PC with windows 10. Last week my pc must have restarted, because when I turned my monitor on, there was no display. I ended up having to manually shut the PC down by holding the power button because it was completely non responsive. Now, when I turn...
  2. Hardware
    I have an ASUS P8Z68-V LE motherboard with an ASUS nvidia geforce GT 710 DDR3 graphics card, 4x8gb corsair vengeance DDR3 ram, with an I7-3770k processor (just installed today, previous I5-2500k), and a team group 1tb SSD with windows 10 installed. My computer won't boot and the DRAM light is...
  3. Hardware
    Hello, so I've had this issue for quite a while now, my monitor shows no display, no bios, no loading screen no anything. However my computer works fine, the fans are spinning too, does it have something to do with the monitor or something?
  4. Hardware
    I have a OLD abs desktop (ABS Desktop PC Dreadnought) After years of using it, I recieved a issue. I get no beep when it boots up. No display is working. Fans are working, lights are on. Usb ports works. However, no beep and no startup just a black screen. No bios either. Not a single display...
  5. Hardware
    I recently bought a PC from my friend about two weeks ago, and the PC was last used three-four weeks ago. Once I set everything up, the PC would not connect to either monitor. I have reset the BIOS, tried connecting it through the motherboard, taken out both the RAM and the GPU, cleaned both. I...
  6. Hardware
    New build with above mo/bo & i9-9900k (not my first build I hasten to add). Got as far as installing Win10 then installed mo/bo drivers and the PC shut down. On restart "no signal" on monitor which was plugged into GTX1060; tried in mo/bo graphics socket, still "no signal". I've removed the GTX...
  7. Hardware
    Today I upgraded my CPU from ryzen 3 1200 to a 5 3600, I followed the instructions and I installed the CPU + Stock wraith fan properly. When I turn on the computer, all the fans start running and the red LED on the motherboard lights up. Only there is no display. Its plugged into my 1050ti,and I...
  8. Hardware
    So about three weeks ago my PC (which is fairly old but still in working older and is also home made) began having issues on startup. It started normally, but after getting to the home screen (Windows 7 operating system) the screen went blank. I currently have it hooked up to my TV rather than a...
  9. Windows 10
    Help please! My toshiba touchscreen has been broken for a long time now, we've just used an hdmi cord to connect it to a TV and used it as the monitor. Well it started acting up, getting slow and freezing so my husband was going to delete and reinstall the network drivers, (he says thats all)...
  10. Hardware
    So, actually iam a kind of poor gamer . I have a low end pc specs: H61H2-M6 V.2 motherboard, Pentium G645 processor, 8GB ram , GT 610 graphics card and an Intex 450watt PSU with 18a on 12v. So, recently I bought a second hand Asus GTX750 Ti oc 2GD5 graphics Card. He said it is working...
  11. Hardware
    Parts CPU: Ryzens 2400g Mobo: Asus rog b450-f Gpu: zotac 1060 6gb mini Ram: Gskill ripjaws 3200mhz PSU: seasonic 550w bronze 80+ Case: gamdias m1a So yesterday my PC was working just fine. I installed a new driver and restarted and it still worked fine. I get on today to find my PC is on (fans...
  12. Hardware
    Hi My gaming pc in the last 3 days was shutting down on its own and would then proceed to boot up for a few seconds and shut off again am guessing this is from over heating so i decised to clean out any dust from inside my pc but now this has left ne with the problem as my pc turns on with power...
  13. Hardware
    Hello my computer was working fine yesterday until I shut it down to put a new ssd in. I opened it up took the gpu out so I could plug in a sata and put my ssd in the back of the case. I then put my gpu back on and get no display. I continue to troubleshoot taking all my ram out and booting with...
  14. Hardware
    Hello there. I built a PC about two years ago for gaming and it was working fine until one day I started having a weird problem. Whenever I would be watching YouTube or playing games, everything just froze and random colour would be shown on the screen. The PC would be running but with fans at...
  15. Hardware
    So i've built a pc, and after some days I changed the stockcooler, after I changed the cooler I booted up the pc. The pc boots up but some usb ports don't work and it shows no Display. I searched for the problem and some people said it was the motherboard that was damaged, so I did that, bought...
  16. Hardware
    I just got my Cyberpowerpc today with an asrock challenger 5700xt + 3600 on an asus x570 prime mobo. My friend and I updated windows and downloaded the chipset, lan, and audio drivers and everything was working fine. When I was installing the latest Radeon drivers, I used the factory reset...
  17. Hardware
    hi i recently built a new amd pc and after doing all of the bios updates and etc. it turns on but no display on monitor. i have tried the "clear CMOS" and after doing that i was able to get into the bios. but then after, it would still not show a display on my monitor. the pc turns on perfectly...
  18. Hardware
    Hi, I recently got a new cpu (Ryzen 5 2600) from a Ryzen 3 1300x. I have 16 gigs, 500 watts, a rx 570, and my motherboard is a gigabyte a320m-hd2. I tried resetting cmos, it’s not a wired issue because when I switch back to the old cpu it boots up, and I also tried using an old gpu that takes no...
  19. Hardware
    I recently got a new power supply because my old one fried in a power surge I got a rm 850x now and it booted my computer all good except from no display to monitors and no USB ports working could it be my MoBo? Has it fried or messed up I tried cmos and cleaning parts but nothing fully starts...
  20. Windows 7
    Hi, so today a heavy like 1kg wooden block accidentally fell on my Cpu, after that my monitor went black, when I restarted it, in the password page it started to look like those broken TV static and static sound came. Can you help me understand what happened? Is my motherboard affected?
1-20 of 45 Results
Top